SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Mar 2007
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy I can't get a simple js page flip effect to work...

    I can't get this to work for NOTHING..been trying a few days now...

    See code below:

    Code HTML4Strict:
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <title>jFlip</title>
    <script type="text/javascript" src="../js/jquery-1.7.1.min.js"></script>
    <script type="text/javascript" src="../js/jquery.jflip-0.4-min.js"></script>
    <script type="text/javascript">
    $(function(){
    	$("#gallery-1").jFlip(600,400,{background:"000",cornersTop:true,scale:"fit"});
    })
    </script>
    </head>
     
    <body>
    <ul id="gallery-1">
      <li>
        <img src="English/KHill-Villa-Broch-pg2.jpg" />
      </li>
     
      <li>
        <img src="English/KHill-Villa-Broch-pg2.jpg" />
      </li>
     
    </ul>
     
    </body>
    </html>

    The js files I used can be found on the net:

    jquery.jflip-0.4.min.js
    jquery-1.7.1.min.js


    Anybody have any idea why this isn't working?

    Tsk..

    Example:
    It's working fine here:
    http://www.jquerymagic.com/wp-content/uploads/jflip/


    Jan
    Attached Files Attached Files

  2. #2
    Unobtrusively zen silver trophybronze trophy
    paul_wilkins's Avatar
    Join Date
    Jan 2007
    Location
    Christchurch, New Zealand
    Posts
    14,702
    Mentioned
    101 Post(s)
    Tagged
    4 Thread(s)
    You may want to take a closer look at the filename for the jFlip script.
    What is in your HTML doesn't match up with the filename in your zip file.
    Programming Group Advisor
    Reference: JavaScript, Quirksmode Validate: HTML Validation, JSLint
    Car is to Carpet as Java is to JavaScript

  3. #3
    SitePoint Member
    Join Date
    Mar 2007
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    WORKED!

    Thanks Paul, that was the problem...tsk, so sad so sad..I'm just sad..little thing like that..who would've thought?

    Again, thanks Paul..


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •