SitePoint Sponsor

User Tag List

Results 1 to 9 of 9

Thread: PHP 5.3

Hybrid View

  1. #1
    SitePoint Zealot
    Join Date
    Oct 2008
    Posts
    167
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP 5.3

    I am just curious as to how many web hosting providers are still using PHP 5.2 as their default PHP version. How many have made the leap to offering PHP 5.3 as their default PHP version?

    I know PHP just recently released version 5.4. I don't suspect a lot of web hosts have moved to PHP 5.4. But I am just wondering what the numbers are for web hosts that use PHP 5.3 vs. web hosts that use PHP 5.2.

    We still have PHP 5.2 by default on our servers, but want to upgrade it to PHP 5.3. But if most web hosts are still using PHP 5.2, then maybe we don't need to be in a huge rush to upgrade to PHP 5.3.

    For web hosts that have upgraded to PHP 5.3, what kind of issues did you experience with the upgrade? What sort of script compatibility issues did you face? Our web hosting users seem to use mostly WordPress, Joomla!, Drupal, Zen Cart, SMF, Coppermine, 4images, and Gallery. Did you experience any compatibility issues with any of these scripts?

  2. #2
    SitePoint Wizard gate2vn's Avatar
    Join Date
    Jan 2004
    Location
    Oslo, Norway
    Posts
    1,057
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Most of them are compatible with PHP 5.3, with the newest releases. However, the old versions that are still maintained might not. For example, Drupal 6 having some modules doesn't compatible with PHP 5.3
    Clustered CloudLinux Hosting | WordPress Hosting |
    Advanced Antispam | Managed Xen VPS
    in US West coast and Asia-Pacific datacenters
    Contact us now on Twitter @vietnap

  3. #3
    Twitter: @TimIgoe silver trophy TimIgoe's Avatar
    Join Date
    Feb 2005
    Location
    Blackpool, UK
    Posts
    1,058
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    Very little issues moving from PHP 5.2 to 5.3 on all the servers / sites I run, I had one really old site that didnt take kindly to the update, we retired that site instead as it wasn't being used anymore.

  4. #4
    SitePoint Addict
    Join Date
    Apr 2011
    Posts
    265
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    When the customers will ask for new php version, or go to other company, they will think to make the update.
    Free: Web Programming Courses HTML, CSS, Flash
    Web Programming: AJAX Course and PHP-MySQL Course video Lessons
    Good JavaScript and jQuery course for beginners

  5. #5
    Non-Member
    Join Date
    Dec 2011
    Posts
    25
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    On shared hosting php upgrade is not so easy as that can affect on hundreds of website. This is why you will find hosts that are using still php 5.2.

  6. #6
    SitePoint Wizard gate2vn's Avatar
    Join Date
    Jan 2004
    Location
    Oslo, Norway
    Posts
    1,057
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Actually, it's not that hard. If customers are serious by using their websites, they will keep their websites updated. And most of open source scripts today are compatible with PHP 5.3. The only script I had issue is vTiger. Other hand-codes sites can adjust easily too.

    Quote Originally Posted by storminternet View Post
    On shared hosting php upgrade is not so easy as that can affect on hundreds of website. This is why you will find hosts that are using still php 5.2.
    Another issue is Zend Optimizer. Zend doesn't provide Optimizer for PHP 5.3. Tried to install OptimizerPlus 4.1, but the files encoded in 5.2 are still not compatible.
    Clustered CloudLinux Hosting | WordPress Hosting |
    Advanced Antispam | Managed Xen VPS
    in US West coast and Asia-Pacific datacenters
    Contact us now on Twitter @vietnap

  7. #7
    SitePoint Enthusiast CrucialWebHost's Avatar
    Join Date
    Jun 2006
    Location
    Arizona
    Posts
    53
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by gate2vn View Post
    Another issue is Zend Optimizer. Zend doesn't provide Optimizer for PHP 5.3. Tried to install OptimizerPlus 4.1, but the files encoded in 5.2 are still not compatible.
    PHP 5.3.x doesn't use Zend Optimizer, it uses Zend Guard Loader instead:

    http://www.zend.com/products/guard/downloads

    We currently run PHP 5.2 as the default PHP version, but will be switching this to PHP 5.3 in 30-45 days. However, we also run PHP 5.3 and PHP 5.4, so clients can choose which version they want to run, and even run all three versions under one account.
    Crucial Web Hosting Our new site is live!
    Introducing Split-Shared and Split-Dedicated
    hosting products! Join our new Developer Network
    and check out the updated Site Showcase!

  8. #8
    SitePoint Wizard gate2vn's Avatar
    Join Date
    Jan 2004
    Location
    Oslo, Norway
    Posts
    1,057
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you read my post again, the point is: files encoded in 5.2 are not compatible with Zend Optimizer Plus, or Zend Guard Loader.
    Clustered CloudLinux Hosting | WordPress Hosting |
    Advanced Antispam | Managed Xen VPS
    in US West coast and Asia-Pacific datacenters
    Contact us now on Twitter @vietnap

  9. #9
    SitePoint Enthusiast CrucialWebHost's Avatar
    Join Date
    Jun 2006
    Location
    Arizona
    Posts
    53
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by gate2vn View Post
    If you read my post again, the point is: files encoded in 5.2 are not compatible with Zend Optimizer Plus, or Zend Guard Loader.
    Sorry, I misread what you wrote. I don't run across many (actually I can't think of any) clients that have Zend encoded files, they all use ionCube, which is supported in 5.3. Most applications that do encode offer both as a download option as well, so there's always that alternative.
    Crucial Web Hosting Our new site is live!
    Introducing Split-Shared and Split-Dedicated
    hosting products! Join our new Developer Network
    and check out the updated Site Showcase!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •