SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Location
    Nova Scotia, Canada
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unwated space above image

    I recently came across an article on doing image rollovers with using CSS instead of Javascript.. so I decided to try it out.

    Works great in IE6 but in Mozilla 1.2b the images are nocked down and half of the rollover image is not visiable...

    I'm not sure exactly why Mozilla is doing this. Can someone please take a look and give me any ideas why... also testing in any other browser is welcome...

    here is the code:

    Code:
    ***edit: code removed

    Thanks,
    Jeremy
    Last edited by novatrails; Nov 12, 2002 at 12:40.

  2. #2
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Location
    Nova Scotia, Canada
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    okay I figured out how to move the images to the top ..and in the process I realized the real problem is the line height...

    I tried setting the line-height to the size of the image but that still doesn't do anything to fix the problem in Mozilla...

    here's a url example of the problem

    ** edit: url removed **
    Last edited by novatrails; Nov 12, 2002 at 12:39.

  3. #3
    SitePoint Wizard Bill Posters's Avatar
    Join Date
    Dec 2001
    Location
    UK
    Posts
    1,523
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Search and remove...

    Code:
    <font size="6">h</font>
    New Plastic Arts: Visual Communication | DesignateOnline

    Mate went to NY and all he got me was this lousy signature

  4. #4
    ********* Streaker Lister14's Avatar
    Join Date
    Jun 2002
    Location
    C:\Documents and Settings\Desktop\Recycle Bin
    Posts
    677
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    looks a bit odd when viewing in a smaller sized window... the 'menus' drop from the top right and 'center' themselves a line(? lots of sapce actually) lower...
    roy.lu
    C:\DOS... C:\DOS\RUN... RUN\DOS\RUN...!

  5. #5
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Location
    Nova Scotia, Canada
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    as for removing the font tag and the letter h that doesn't help.. it's the only reson that the one image shows properly...

    if I take it away then the image only shows half like all the rest...

    As for smaller windows it's being designed for at least 800x600

    anyway.. I figured out that the images are only showing half because of the browser thinking it only needs to desplay what ever the height of the text is and wen there is not text it deaults to a size smaller then my image...

    so I've put it aside for now..and will look at it again when I have more time.

  6. #6
    SitePoint Wizard Bill Posters's Avatar
    Join Date
    Dec 2001
    Location
    UK
    Posts
    1,523
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fwiw, I tried the url you had posted previously again after a while.
    It seemed to have been fixed in Moz 1.0.1 Mac.

    I was going to post to ask if you had made any changes to the example while it had been online.

    I had a brief play around with the code locally (using your remote images) and found that the DTD had an effect on the vertical placement of the nav buttons.
    I changed it to strict and they seemed to rise up, but not completely.

    Not sure if that helps, but maybe worth looking into.
    New Plastic Arts: Visual Communication | DesignateOnline

    Mate went to NY and all he got me was this lousy signature


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •