In corresponding with techs for a web host I have to publish on for a client, I got these replies.

I asked them to upgrade from Php 4.0.6 to at least 4.1.0 or if possible 4.2.3.

These are the replies that I got.

Unfortunately, we are not able to install PHP version 4.10 onto the server your site is hosted on at this time. We feel that PHP 4.10 has too many security flaws to safely be installed onto the server at this time. Eventually, when these flaws are corrected, we will install a newer version of PHP.

PHP is compiled within the linux operating system that is on the server. There is no feasible way to upgrade the version of PHP on the server at this time.
What do you think of this? What are the issues I can research to discuss this with them. Are they correct?

I know a wee bit about Linux, and it seems to me that Php is compiled as a part of Apache not as a part of the 'Linux operating system'. Isn't their statement about that B.S.?

If you need more info to help me answer this, ask me please and I'll answer it.

Jeff