SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Feb 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Having trouble understanding DNS records

    When I view my domain's DNS records via WHM, I don't see any A records pointing to my server's public IP address. The only A records I see point to 10.x.x.x, which is is a private IP address, correct? If this is the case, what gives? I'm just trying to develop an understanding of exactly how requests find their way to my server and I'm completely baffled by the DNS records I'm seeing. I would appreciate any help you can offer! Thank you.

  2. #2
    Twitter: @TimIgoe silver trophy TimIgoe's Avatar
    Join Date
    Feb 2005
    Location
    Blackpool, UK
    Posts
    1,058
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    10.x is a completely private address, yes.

    Its possible that the WHM setup is in correct or the server you are on is part of some more complex setup.

    Is the DNS definiately being controlled for your domain via WHM and not via another 3rd party ?

  3. #3
    SitePoint Enthusiast ideamine's Avatar
    Join Date
    Feb 2012
    Location
    Queen of Arabian Sea
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have a check with the namseservers via dig or domain dossier. Cpanel values will be correct only if the same server is your nameserver.

  4. #4
    SitePoint Member
    Join Date
    Feb 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I would assume that the DNS is being controlled via WHM. I'm not sure how I would check this. I did use domain dossier (very cool tool btw), but I don't know what I am looking for to confirm that my WHM is actually controlling my domain's DNS records. The NS records shown by domain dossier do match the ones in WHM.

    After some more observation I did notice something. In cpanel, it shows that the last IP to log in to cpanel was 127.0.0.1 and that the server's dedicated IP address is that same 10.x.x.x IP. These values seem strange as well. At my previous web host, the last IP to log in was my IP and the server's dedicated IP was its public IP. Could it be that the DNS records really are pointing to the public IP, but for whatever reason it's showing up as the private IP? Seems wacky.

  5. #5
    SitePoint Member
    Join Date
    Feb 2012
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Its possible that the WHM setup is in correct or the server you are on is part of some more complex setup.
    Turns out that this was the case. My web host translates the private IPs to the public IPs when updating their nameserver. Thank you for your help, everyone. I appreciate it!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •