SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2009
    Location
    A city equidistant from two coasts of India.
    Posts
    47
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Application starts picking old cached obsolete data anywhere.

    My application is built on ASP.NET 2.0 and is hosted on a dedicated server running Windows Server 2008 R2.

    From the last few days, my users are complaining that the application starts malfunctioning by picking previous SQL Server connection values. The GridView starts displaying options of a DropDown control and so on. When I restart the SQL Server background service, everything starts working fine. I had a lot of discussion with people and few suggested that it has something to do with the Application Pool.

    I looked into the IIS properties to see which application pool is running my application. I found that my application is using Classic Application Pool with Managed Pipeline Mode set to: Classic. The application is also running with Application Pool Identity: LocalSystemAccount.

    In the database connection string (in web.config file), I am using Server Name as LocalHost with Integrated Security=SSPI.

    I want to know whether the above settings have anything to do with this malfunction.

    Do I need to change the Pipeline Mode to Integrated and put the application in a separate pool? Is Integrated Security=SSPI has anything to do with the PipeLine Mode?

  2. #2
    SitePoint Enthusiast WindowsHosting's Avatar
    Join Date
    Feb 2009
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    You should check the:

    - user session
    - cache
    - application pool timeout property

    Regards
    Find Free ASP.NET hosting information and resources at http://www.windowshostingasp.net.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •