SitePoint Sponsor

User Tag List

Results 1 to 19 of 19
  1. #1
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Website internal page are invalid in social bookmarking sites..why?

    Hi Guys,

    I am back with another issue for you.

    When I am submitting the internal pages of my website in social bookmarking sites, all sites are showing error message "Invalid page". I don't know why this is happening and none of the bookmarking site is showing the reason why internal pages are invalid. I am not giving the website name here but giving you the example of page: abc.com/deals/london
    all pages are like /deals/london, /deals/cardif....
    If anyone knows the reason or solution how to get rid of this please reply fast. I am in very much need of this solution.

  2. #2
    SitePoint Wizard bronze trophy Immerse's Avatar
    Join Date
    Mar 2006
    Location
    Netherlands
    Posts
    1,661
    Mentioned
    7 Post(s)
    Tagged
    1 Thread(s)
    Which sites exactly are 'all sites'? Can you name one where it shows the error 'Invalid page'? (you don't have to name them all, one should be enough).

  3. #3
    Word Painter silver trophy Shyflower's Avatar
    Join Date
    Oct 2003
    Location
    Winona, MN USA
    Posts
    10,053
    Mentioned
    142 Post(s)
    Tagged
    2 Thread(s)
    Could you post a screenshot of the invalid message? Maybe that would help as well.
    Linda Jenkinson
    "Say what you mean. Mean what you say. But don't say it mean." ~Unknown

  4. #4
    SitePoint Wizard
    Join Date
    Dec 2003
    Location
    USA
    Posts
    2,582
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    Double-check that the URL is valid. Are you submitting manually or with a program? Also, they may be picky, so make sure you have "http://" at the beginning.

  5. #5
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by samanime View Post
    Double-check that the URL is valid. Are you submitting manually or with a program? Also, they may be picky, so make sure you have "http://" at the beginning.

    I can't give my website name here but yes I am submitting it manually as http://www.abc.com/deals/london. Yesterday I was trying to submit a facebook page(http://www.facebook.com/websitename) on social bookmarking site but it showing same error "Invalid URL"..

  6. #6
    SitePoint Wizard
    Join Date
    Dec 2003
    Location
    USA
    Posts
    2,582
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    Which bookmarking sites? Maybe they don't allow subpages.

  7. #7
    Wired Life GeraldNitram's Avatar
    Join Date
    Jan 2012
    Posts
    274
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    I don't know if this would be related to the problem, but is that a business page you're submitting, or is that a personal profile page? Either way, can you access that page even if you're logged out of Facebook? There are some accounts that you think are public, but you can't access them when you're logged out. I think that could be one of the triggers of the "Invalid URL" message.

  8. #8
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by samanime View Post
    Which bookmarking sites? Maybe they don't allow subpages.
    yes I want to know why these sites don't allow subpages or is there another way to submit submit subpages?

  9. #9
    SitePoint Wizard
    Join Date
    Dec 2003
    Location
    USA
    Posts
    2,582
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    If you told us what bookmarking sites they were, maybe we could tell you. There isn't a "Unverisal Rules for All Social Bookmarking Sites" handbook. Each social bookmarking site is completely different. =p

  10. #10
    Non-Member Johnletton's Avatar
    Join Date
    Jun 2011
    Location
    California, USA
    Posts
    38
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't think that this error could be show because i personally have submitted many internal pagaes of my website in various social media site. However, there could be a one problem that you are submitting your internal page without http:// extention if you are missing these characters then you can't submit these page in social media sites because before a day i had to face this error and when i noticed that i am refusing these characters so after add these characters my pages submitted.

  11. #11
    SitePoint Member
    Join Date
    Feb 2012
    Location
    San Diego, CA
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have been posting my internal pages into several Social Bookmarking site for almost 13 months. I haven't face such problem, there might some other issue. You might be using wrong submission method.

  12. #12
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by samanime View Post
    If you told us what bookmarking sites they were, maybe we could tell you. There isn't a "Unverisal Rules for All Social Bookmarking Sites" handbook. Each social bookmarking site is completely different. =p
    I am using social bookmarking list from socialmaximizer.com.....

  13. #13
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by sophia123789 View Post
    I have been posting my internal pages into several Social Bookmarking site for almost 13 months. I haven't face such problem, there might some other issue. You might be using wrong submission method.
    Hi Sophia,

    Here is my website home page https://www.abc.com/default.aspx. would i need to submit as it is or as https://www.abc.com/ can u please tell me?
    Last edited by Stevie D; Feb 15, 2012 at 04:34.

  14. #14
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by seo.xpert View Post
    Hi Sophia,

    Here is my website home page https://www.abc.com/default.aspx. would i need to submit as it is or as https://www.abc.com/ can u please tell me?
    when I am submitting this website on web directory "explorarapanui.com" ....it showing error "The URL could not be validated. Either the page does not exist or the server cound not be contacted". showing same error on all web directories..even i have tried to submit after removing /default.aspx but still showing same error msg..why? I have used "abc" as example because i can't give my website name here..
    Last edited by Stevie D; Feb 15, 2012 at 04:34.

  15. #15
    Word Painter silver trophy Shyflower's Avatar
    Join Date
    Oct 2003
    Location
    Winona, MN USA
    Posts
    10,053
    Mentioned
    142 Post(s)
    Tagged
    2 Thread(s)
    I think the problem may be in your SSL certificate. See if either of these two links can help you:

    http://www.verisign.com/ssl/ssl-info...ics/index.html
    https://ssl.trustwave.com/support/su...validation.php
    Linda Jenkinson
    "Say what you mean. Mean what you say. But don't say it mean." ~Unknown

  16. #16
    SitePoint Member
    Join Date
    Feb 2012
    Location
    San Diego, CA
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i think this doesn't matter but still try https://www.abc.com/..... but your internal page should be like https://www.abc.com/ABC/DFE ? The URL sample you mention is for main page or home page. In my experience there should not be any problem in while submitting internal page.

  17. #17
    SitePoint Member
    Join Date
    Feb 2012
    Location
    San Diego, CA
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    for directories submission internal links most of they time are not accepted....there are directories with the option internal linking....search those directories

  18. #18
    Non-Member
    Join Date
    Sep 2011
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Shyflower View Post
    I think the problem may be in your SSL certificate. See if either of these two links can help you:

    http://www.verisign.com/ssl/ssl-info...ics/index.html
    https://ssl.trustwave.com/support/su...validation.php
    Hi,

    I think you are right there is problem with SSL. I have 2 more same websites with same URLs but don't have SSL and there is no error while I am submitting these websites. So please can you let me know how can I resolve my problem? I have to remove SSL or can I solve it without removing SSL?

  19. #19
    Word Painter silver trophy Shyflower's Avatar
    Join Date
    Oct 2003
    Location
    Winona, MN USA
    Posts
    10,053
    Mentioned
    142 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by seo.xpert View Post
    Hi,

    I think you are right there is problem with SSL. I have 2 more same websites with same URLs but don't have SSL and there is no error while I am submitting these websites. So please can you let me know how can I resolve my problem? I have to remove SSL or can I solve it without removing SSL?
    Well if https urls can't be submitted, then I guess you would have to remove the SSL. However, if that is there for a good security reason, it might not be in your best interest to do so. It depends on why you are using the SSL for your pages.

    I also think that Sophia123789 is right in her post #17. Some directories just don't take internal pages. Your best bet is to ask for help from those directories that are problematic. They could probably tell you what is acceptable and what is not.
    Linda Jenkinson
    "Say what you mean. Mean what you say. But don't say it mean." ~Unknown


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •