SitePoint Sponsor

User Tag List

Page 6 of 8 FirstFirst ... 2345678 LastLast
Results 126 to 150 of 184
  1. #126
    SitePoint Wizard
    Join Date
    Oct 2001
    Location
    Lancaster, PA
    Posts
    3,019
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Hey Harry -

    Ok, checked it out with "whereis convert" through SSH and found it at /usr/local/bin/convert

    However...even after making the changes in my site.ini.php file - it still wont work My ini file classes look like

    AdminTemplateDir=templates/standard/

    TemplateDir=templates/standard/

    ImageConversionProgram=/usr/local/bin/convert

    DefaultSection=1
    Aargh...what in the world am I missing?

    Should I try an installation using their installer "ezinstaller.sh" ??

    Thanks for your help here Harry!

    Steve
    Last edited by Ravedesigns; Jan 6, 2003 at 14:23.
    Web Designer or Small Business Owner?
    Need More Leads and More Clients?
    Get Free Marketing Tips, Tricks and Ideas Here!

  2. #127
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Wink Installing eZ-3.0

    Hello everybody!
    I've tried to install ez3.0 on vhost. There is a problem I will try to explain:

    for some reason it(ez)puts double slash and substitutes index.php4 to index_php4 after configuration.

    have no answer till now (may be because we don't have access to the shell?). Is there any trick which might help to vhoster?

  3. #128
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fatal error

    I did get a supposedly successful install (see below) but also have the double slashes.

    Here is an error I get when going to quite a few of the pages
    PHP Code:
    Fatal erroreZ publish did not finish it's request

    The execution of eZ publish was abruptly ended, the debug output is present below. 
    This is the report on my install process, in the event it may be of use to someone.

    Running on a shared LAMP hosting environment.

    In my never ending quest to find a more efficient way to handle a database driven site, I've been reading a good bit about OOP and specifically about ezPublish from Harry Fuecks article on Sitepoint at http://www.webmasterbase.com/printTemplate.php?aid=917

    I downloaded the 3.0 beta release version 4 -- ezPublish-2.9-6.zip Thanks to help from Melissa, I moved the zip file to my /big/dom/xcoastaloutdoors/www folder and used Telnet to unzip the file.

    Tried following Harry's instructions but didn't quite get me there.

    Tried these instructions but didn't accomplish the goal.

    Begin Instructions

    In step 7 of the Windows installation above, we used a DOS batch file to create the cache directories. The Linux equivalent is the file called modfix.sh, which you can run by changing the [eZ publish_root] on your server and typing:

    ./modfix.sh

    Note this file also sets up security permissions on the cache directories which are not entirely secure (although the risk is low). And alternative secure_modfix.sh exists, but you'll probably run into trouble if you use this in a typical shared Linux environment.

    To make use of Image Magick, the convert binary needs to be installed on the Web server. Time to beg your Web host for a favour (it's not hard for them to install), and get them to tell you where they put it.

    End Instructions

    So, this is what I did -- used CuteFTP to chmod the files below:

    chmod settings 777
    chmod var 777
    chmod var/storage 777
    chmod var/cache 777
    chmod var/log 777
    chmod var/cache/texttoimage 777
    chmod var/cache/ini 777
    chmod var/cache/template 777
    chmod var/cache/template/tree 777
    chmod var/cache/template/process 777

    I got to the "create database" stage, "check to install demo data" but only got a blank page.

    Looked for the sql file --- found in /kernel/mysql/ downloaded both demokernel.sql and kernel_clean.sql, Decided to use the demokernel.sql file. Used phpmyadmin to upload the sql a few hundred lines at the time since there are in excess of 10,000 lines in the demokernel.sql and phpmyadmin times out at 30 seconds on my server.

    Anyway once that was completed, backed up, refreshed, and selected "Continue and skip database initialization."

    Got as far as the "send registration" and am sending these comments -- an apparently successful install I hope.

    I was able to login to the admin site. That's all I'm going to do tonight -- need to get at least a couple hours of sleep. The speed appears to be pretty good. If anyone is interested, I'll keep you posted on my progress. Haven't gotten around to the Image Magick part yet.

    I will begin Harry's Part 2 today or tomorrow.
    Coastal Outdoors
    Fishing, boating, outdoor fun on the coast.

  4. #129
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    eZ publish 3 (2_9.x) is still not officially released - it's a release candidate which means there will be bugs and problems.

    Also, having had a look at it now, it's alot different from the the version I wrote the article about - 2_2_6

    Although 3.x will be alot easier to use and maintain (plus loads of new features), think it's best to wait before spending any serious time on it right now.

  5. #130
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Harry. I think I'll go back and install the earlier version so that I can have help from everyone here in working through the concept.

    BTW, I left a comment on your DAO Patterns article regarding a link to the Goaq DAO pattern -- not sure I got the right one. The one I got was to a martial arts video.

    Your articles have been among the very best I have read. They are clearly written. They also help those of us who don't already have an indepth understanding of programming to bridge the gap between some of the basic concepts and the more advanced concepts.
    Coastal Outdoors
    Fishing, boating, outdoor fun on the coast.

  6. #131
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks alot! Really appreciate it. Goaq Dao was just me fooling around BTW.

  7. #132
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks to all of you!

    we'll still try to cope wiht this problem. I think that we're going to find the way out.

    Looking forward to the release of 3.0. By the way, is anyone know when it is scheduled for?

    Have a good one!

  8. #133
    SitePoint Enthusiast
    Join Date
    Aug 2002
    Posts
    35
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I read some place, one of the ez forums I think, which said ez3 was NOT supposed to run with Safe Mode ON in PHP. I think I read in other places that it IS supposed to run with Safe Mode on. I DO have ez3 installed on the LAMP with Safe Mode ON.

    I read the following on one of the ezpub forums -- ez3 I think. It was specifically concerning viewing the user pages I think but may help. For the ez forums, go to ezPublisher Developer site scroll to the bottom of the page and you'll see the forums. Check out the ezpublisher3 forum.

    Try this:

    http://localhost/<your ezpublish directory> /index.php/user

    and this for your admin:

    http://localhost/<your ezpublish directory> /index.php/admin

    it simply involves appending /<user or admin or whatever user u create> after index.php. Ironically I found this in the "hidden" documentation in one of the directories under installation for linux or something. (i'm testing this on win2k though)

    the rest of it involves tweaking around with your settings/site.ini.php and your settings/siteaccess/user/site.ini.append and settings/siteaccess/admin/site.ini.append

    must say documentation for 2.X is way better than 3.
    Coastal Outdoors
    Fishing, boating, outdoor fun on the coast.

  9. #134
    SitePoint Member
    Join Date
    Jan 2003
    Location
    Birmingham, UK.
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry HELP! It's working but...

    I've got ezpublish working on the shared (RedHat 7, Apache 1.3 etc) server that I use, I'm really pleased with it... installed like a dream...

    I've even been able to install the version 3 that's available for download...

    HOWEVER

    When I try to follow the homework! (yes I always was a swot) I can't!

    I can't delete any categories, when I try to it just throws the 'add new image' etc window up.

    If I try to add a new image, it doesn't let me either!

    I fill in all of the details, then click go, and I get an error saying need to fix the following: must supply a name, must supply a file.

    WELL I DID, INFACT I'VE DONE IT A MILLION TIMES!

    Please help. I've executed modfix.sh, I can't think of anything else to try, permissions are ok with mysql (I've tried running as root).

    I'm a Linux novice, so please be gentle.

    Thanks

    P

  10. #135
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Two quick thoughts. Register globals - are they on?

    Otherwise what about the filesize? I think ez publish gives that message if the file is too big.

  11. #136
    SitePoint Member
    Join Date
    Jan 2003
    Location
    Birmingham, UK.
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question

    regsiter globals is on : yes
    filesize : 2KB

    I would think that it should work.

    But alas!

    Any other ideas, PLEASE!

    P

  12. #137
    SitePoint Member
    Join Date
    Jan 2003
    Location
    Birmingham, UK.
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile duh! I've done it!

    I've solved my own problem!

    http upload was turned off in my php.ini!

    Never mind. All sorted now, it's working like a dream.

    Harry, will you be doing an article on version 3 when it becomes a complete reality?

    Thanks and all the best

    P

  13. #138
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Harry, will you be doing an article on version 3 when it becomes a complete reality?
    May be - time is always never enough. There's a good chance though that eZ publish 3 will have good documentation anyway, that being one of the things Bard mentioned would be significantly improved. I've only played with 3.x so far and it's very easy to install and at a glance looks even better designed...

  14. #139
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    I'm new here. Stumbled upon the article and tried the install, as I realised that EzPublish was just what I need.

    I'm using shared hosting with no SSH access, however I've got a good way along (I think )

    However, I get this error when trying to visit my site:
    "Fatal error: Call to undefined function: xmltree() in /home/thebloor/public_html/ezarticle/classes/ezqdomrenderer.php on line 235".

    According to the servers phpinfo, register globals is on, apache is 1.3.27 etc.

    Any thoughts please?

    Jon

  15. #140
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    "Fatal error: Call to undefined function: xmltree() in /home/thebloor/public_html/ezarticle/classes/ezqdomrenderer.php on line 235".
    You need to slap your hosting company - they haven't installed the PHP XML extension which these days there's no excuse for.

    eZ Publish 3.0 RC Installation

    Just for fun thought I'd slap this here;

    1. Download the release candidate and extract under your web root e.g. c:\htdocs\ezpublish
    2. Create a MySQL database called ezpublish_3
    3. Point your browser at http://localhost/ezpublish and follow the instructions
    4. When finished head to http://localhost/ezpublish/index.php/user/ to see the user front end

    Nuff said Just a little teaser...

  16. #141
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks They are installing it in their weekly updated on Wednesday.

    Jon

  17. #142
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Change naming convention

    Hi all,


    firstly, my congratulations for excelent work in ezpublish 2.2.6. Great work... I'm looking for any help to this:


    This is the "default" convention in ezpublish web address, ok:


    http://localhost/index.php/article/articleview/17/1/1/

    http://localhost/index.php/article/a...static/12/1/1/


    Is possible change this address for example:

    from: http://localhost/index.php/article/articleview/17/1/1/

    to: http://localhost/index.php/artigos/artigosview/17/1/1/


    from: http://localhost/index.php/article/a...static/12/1/1/

    to: http://localhost/index.php/artigo/ar...tatico/12/1/1/


    This is a simple example. In resume: is possible change the "default" naming convention?


    Thanx a lot for all.


    Success in 2003.

  18. #143
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclude from moderator person

    Hi all,

    is possible to exclude the moderator where user send a article??? I want article send instantly to site, without moderator.


    Is possible??

    Thanx...

    Spectrum

  19. #144
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is a simple example. In resume: is possible change the "default" naming convention?
    In theory yes it is. If you change the name of the eZ article module in site.ini(.php) to ezartigo it should do it. Having said that there may be parts of eZ publish 2.x where the name of the ez article module is hard coded, such as in a template HTML link. Best try it (in a development environment) and see what happens.

    I want article send instantly to site, without moderator.
    Again in site.ini(.php) under the eZ article module there's the setting;

    Code:
    CanUserPublish=disabled
    I haven't tried it so can't speak for it's behaviour (could be the self destruct button ) but my guess is if you switch that on, when a user submits an article it will be published straight away.

  20. #145
    SitePoint Member
    Join Date
    Jan 2003
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Shared Server Installation

    Well, I installed eZ Publish 3 on my local server (Mac OS X Jaguar) in under 20 minutes without any problems, nice and painless.

    Now I need to install it on the shared server space I rent from my hosting provider (Magic Moments).

    My Web space with Magic Moments includes the standard LAMP settup, but does not include command line access.

    Everything went well with the installation, but the URL paths are not working properly.

    I put eZ Publish in a sub directory called "ezpub":

    http://www.site.co.uk/ezpub/

    eZ Publish will take me to

    http://www.site.co.uk/ezpub/ezpub/class/grouplist/

    rather than

    http://www.site.co.uk/ezpub/index.php/class/grouplist/

    and will of course throw up a "Not Found" error.

    Any ideas were I might have a setting wrong somewhere?

  21. #146
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think this is all controlled in site.ini now with eZ publish 3 (haven't given it a thorough examination yet - waiting for the official release of 3 before I give it any serious time). There's definately some answers in the eZ publish 3 forum though: http://developer.ez.no/forum/messagelist/199/

    PS: Demand SSH access to your site!

  22. #147
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    One further thing to note on eZ publish 3 - just found the tutorials.

    The introduction is here: http://sdk.ez.no/sdk/tutorials/view/main_concepts plus there's more if you look on the LHS menu.

  23. #148
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Warning: PHP 4.3.0 and eZpublish 2.x

    You may well get an error message, using PHP 4.3.0, like "cannot redeclare addZero() in classes/eztime.php".

    This is because a function called addZero() appears twice in the class eZTime (in [ezpublish_root]/classes/eztime.php ). The fix is simple - comment out the second declaration of addZero in that class (begins near the end of line 340).

    It seems that with previous version of PHP, it didn't check if you'd declared a function twice within a class.

    My host kindly helped me find this one, by upgrading to PHP 4.3.0 without any warning on a Saturday morning

  24. #149
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just spreading the word: eZ publish 3 is now out: they've updated their site using it: http://developer.ez.no/

    Upgrade scripts from 2 to 3 have yet to be written apparently

  25. #150
    SitePoint Member
    Join Date
    Mar 2003
    Location
    NH
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I downloaded and unzipped and ftped 3.0 to my website. From there I was able to go through the setup screens, including the database part and had no problems. At the last setup screen when I click done I just go back to the beginning of setup. I've done this over and over and over at least a dozen times and I can never get further then clicking on "done" and boom!!! I'm back at the start..

    Anyone have any ideas? as a non programmer I don't find all of this very well documented at all. It's like trying to beat my head against the wall trying to figure out how to install 3.0..

    Oh well I guess I could wait a year for it all to be figured out..

    Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •