SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    Quake 1 Addict CreedFeed's Avatar
    Join Date
    Feb 2002
    Location
    Milwaukee, WI
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Another Accessibility Design Issue

    >>> EDIT: Problem has been resolved. Thread can be closed if admins wish to <<<

    I've got a form with a file field (input box with a "Browse" button) and a submit button (with a name, say "submit").

    When the form submits, it calls itself and the PHP script checks if $submit has a value. If it does, it process the form (uploads the file to the server). It works fine, except I'm having a problem getting it to work with Access Tech Equipment. The script isn't assigning $submit a value when using the equipment and submitting the form. I thought the problem would be that if you don't actually press the button the $submit variable won't receive a value, so I changed the form action to file.php?submit=yes and the same error occurs... the page is erroring out when it checks if $submit has a value

    PHP Code:
    if($submit) {
    --- do 
    stuff here ---
    } else {
       echo 
    "Error occured";

    The "Error occured" message keeps displaying which would mean that $submit isn't receiving a value -- but it works fine if you submit the form normally (without Access equpiment)... any ideas on why this would occur?
    Last edited by CreedFeed; Nov 1, 2002 at 07:15.
    -- Steve Caponetto
    Quake 1 Resurrection :: CreedFeed

  2. #2
    + platinum's Avatar
    Join Date
    Jun 2001
    Location
    Adelaide, Australia
    Posts
    6,441
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    shouldn't you be using

    PHP Code:
    if(isset($submit)) {
    --- do 
    stuff here ---
    } else {
       echo 
    "Error occured";

    or am I up the creek with what the problem is

  3. #3
    Quake 1 Addict CreedFeed's Avatar
    Join Date
    Feb 2002
    Location
    Milwaukee, WI
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, probably, but that really doesn't matter as it relates to the problem...

    Anyways, thanks for reading over the post. I've found the error.
    -- Steve Caponetto
    Quake 1 Resurrection :: CreedFeed

  4. #4
    gingham dress, army boots... silver trophy redux's Avatar
    Join Date
    Apr 2002
    Location
    Salford / Manchester / UK
    Posts
    4,838
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    would you care to share what the problem and related solution actually were ?
    re·dux (adj.): brought back; returned. used postpositively
    [latin : re-, re- + dux, leader; see duke.]
    WaSP Accessibility Task Force Member
    splintered.co.uk | photographia.co.uk | redux.deviantart.com

  5. #5
    Prolific Blogger silver trophy Technosailor's Avatar
    Join Date
    Jun 2001
    Location
    Before These Crowded Streets
    Posts
    9,446
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    probably would be a PHP 4.2+ issue

    instead of
    PHP Code:
    if($submit
    it would be:
    PHP Code:
    if($_POST['submit']) 
    Just a guess.

    Aaron
    Aaron Brazell
    Technosailor



  6. #6
    Quake 1 Addict CreedFeed's Avatar
    Join Date
    Feb 2002
    Location
    Milwaukee, WI
    Posts
    296
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The problem had nothign to do with PHP. That's all I care to get into right now Thanks though!
    -- Steve Caponetto
    Quake 1 Resurrection :: CreedFeed


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •