SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Dec 2009
    Posts
    321
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Simple Slide Show Not working

    Home page on this site www.propertieswithstyle.com

    There are 12 pictures that rotate every 6 seconds.

    They've stopped rotating? ? ?

    I've double checked the code from http://www.javascriptkit.com/howto/show2.shtml

    I'm perplexed.

    Thanks . . . Rick

  2. #2
    SitePoint Addict
    Join Date
    Dec 2009
    Posts
    321
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    I think it's in the DOC Type Structure

    Quote Originally Posted by R Schreiber View Post
    Home page on this site www.propertieswithstyle.com

    There are 12 pictures that rotate every 6 seconds.

    They've stopped rotating? ? ?

    I've double checked the code from http://www.javascriptkit.com/howto/show2.shtml

    I'm perplexed.

    Thanks . . . Rick
    As I'm trying to validate the index.html page I'm beginning to believe that it's in the flow of:
    <html>
    <head>
    <body> etc., placement on the page.

    multiple error: tag:"html allows optional closing tag" validation will proceed as if context is closed." XHTML 1,0 STRICT

    last error: No starting html was found for: "html", or it was closed to many times.

    I can't seem to Google the proper placement of these for my particular index.html page.

    Thanks . . . Rick

  3. #3
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,356
    Mentioned
    268 Post(s)
    Tagged
    5 Thread(s)
    You have an error here:
    Code:
    </script>
    <head>
    
    <body>
    That should be a closing head tag - </head>

  4. #4
    SitePoint Addict
    Join Date
    Dec 2009
    Posts
    321
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    javascript needed name="slide" it was missing.

    Here was the problem - the code did not have this . . . name="slide" I have no idea ho it got deleted!

    javascript needed name="slide" to function.

    How am I ever going to learn all of this?

    <div class="header">
    <img src="../css/images/hpcdmlookout.png" name="slide" width="880" height="320" alt="picture slide show"/>
    </div>

  5. #5
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,356
    Mentioned
    268 Post(s)
    Tagged
    5 Thread(s)
    You should validate your code again, because you still have errors that could cause unexpected results, including two opening <body> tags. The extra one is here:
    Code:
    </script>
    <!-- here is where the main menu and the rest of the page code goes-->
    <body>
    	
    
    	<div id="nav">


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •