SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Aug 2002
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    search script <form> submit "problem"

    I have modified a search script and set it up on a site, here is the searchscript url http://www.smsporten.com/dgssearch/search.php , but if you look at http://www.smsporten.com/tullball3.html source info you can see that there is a pulldownmenu and 'ringetoner' (push the menu) points to the search script.. how can i make it so when people writes something in the text box it submits the text to the search script? if you see what i mean.. (sucks at explaining things)

    thx for all help

  2. #2
    Web-coding NINJA! silver trophy beetle's Avatar
    Join Date
    Jul 2002
    Location
    Dallas, TX
    Posts
    2,900
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just a quick look at the DGS search error page form gives you the info you need
    Code:
    		<FORM METHOD="get" ACTION="http://www.smsporten.com/dgssearch/search.php" TARGET="_self">
    			<FONT FACE="Arial, Sans-Serif, Helvetica"><B>Query:</B></FONT>&nbsp;
    			<INPUT TYPE="text" NAME="q" VALUE="" SIZE="30" TABINDEX="1">
    			<INPUT TYPE="hidden" NAME="r" VALUE="10">
    			<INPUT TYPE="submit" VALUE="Search">
    		</FORM>
    Looks like the search field needs to be named "q" and a hidden field "r" needs to be in place as well...
    beetle a.k.a. Peter Bailey
    blogs: php | prophp | security | design | zen | software
    refs: dhtml | gecko | prototype | phpdocs | unicode | charsets
    tools: ide | ftp | regex | ffdev




  3. #3
    SitePoint Member
    Join Date
    Aug 2002
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm i have done as you told me but i still cant get it to work.. something im still doing wrong?

    Kristoffer

  4. #4
    Web-coding NINJA! silver trophy beetle's Avatar
    Join Date
    Jul 2002
    Location
    Dallas, TX
    Posts
    2,900
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I dunno, have you checked with the DGS documentation to make sure you've set it up correctly?
    beetle a.k.a. Peter Bailey
    blogs: php | prophp | security | design | zen | software
    refs: dhtml | gecko | prototype | phpdocs | unicode | charsets
    tools: ide | ftp | regex | ffdev





Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •