SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Guru hifigrafix's Avatar
    Join Date
    Oct 2005
    Location
    Nashville, TN
    Posts
    628
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Client Occasionally Having Trouble Seeing Their Site

    Greetings,

    I'm having a very strange issue. In addition I apologize if this isn't the appropriate forum for this kind of question. I host dozens of sites on 2 separate dedicated servers.

    I've got a very important client right now who has complained at least 4 times that they can't see their website. Today it happened and they called me right away and I checked and the website came up just fine. I checked the site on my mobile and it came up just fine.

    Now I've ruled out the typical dumbass mistakes that clients usually make and this client in particular is extremely savvy and adept at this kind of thing.

    The client pulled up terminal and "pinged" the domain where they received a notice that it couldn't resolve - unknown host.

    Geographically I am located about 4 blocks from the client on the same ISP.

    Does anyone have any clues as to what I can do. The client manages a number of websites and claims this is the only one she has problems seeing. It's extremely embarassing. I haven't had any other issues with any websites. In addition I'm using mon.itor.us to monitor the health of the site and haven't had an error since 12 months ago.

    Any Ideas?

    Thanks

  2. #2
    Twitter: @TimIgoe silver trophy TimIgoe's Avatar
    Join Date
    Feb 2005
    Location
    Blackpool, UK
    Posts
    1,058
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    Does the client have any fancy internal setup of their network that could be impeeding access to the server?

    There are often random routing issues - if the ISP is an ADSL based one, are you both on the SAME exchange? If you are on different, its possible that there could be issues between exchanges and upsttream.

    One thing I do when having DNS related issues (though I have access to a Linux machine to do this) is a 'dig +trace' to trace through each step to find the potential problems.

    If it is DNS, is it possible you could set up another, test, dns server on a completely different provider for this client - to give them another place to talk to? Is the dns hosted on your servers or elsewhere?

  3. #3
    SitePoint Wizard
    Join Date
    Oct 2005
    Posts
    1,849
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    It sounds like a DNS issue or a routing problem. I have these problems rarely, but I do have them.

    Usually, when I have this type of problem it is a DNS issue with my ISP or my domain name registrar that hosts my domain names. One test is to access the site via IP address. If I can access the site using the IP address and not by entering the domain name, I know there is no problem with the server. It has to be a DNS problem.

    Several years ago, the web host I used had a problem with requests basically getting lost in the data center. Doing a traceroute, I discovered that pings would make it to the data center then time out. This happened not very often, maybe only one out of every 20 page requests. But it did happen and it was not the fault of my web host but the data center.

    You have a savvy client? Did the client:

    1) Try accessing the site via IP address (if possible)?
    2) Try using a HTTP proxy like hidemyass.com?
    3) Try flushing their DNS cache?

    If the site can be accessed by IP address, it's a DNS issue either at the ISP or DNS host. If the site can be accessed using a HTTP proxy, it could be a ISP DNS or routing issue somewhere along the line. If the site can be accessed after flushing the DNS cache, then it's a DNS issue.

    I'm sure there are other tests to try and narrow down the cause. Perhaps others can contribute some ideas.

  4. #4
    Non-Member
    Join Date
    Apr 2010
    Posts
    298
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have seen this issue before and it could be that the client's browser is caching the pages. Tell them to clear the cache so it can redownload the entire page.

  5. #5
    SitePoint Guru hifigrafix's Avatar
    Join Date
    Oct 2005
    Location
    Nashville, TN
    Posts
    628
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey All - thanks so much for your input. It's somewhat re-assuring that other people have these troubles as well..

    Unfortunately I don't have the ability to bind the site to an IP address on this server. I will have her run a traceroute next time. In addition I will have her use a proxy to try and view the site when it's down on her browser.

    I'll let you know what we come up with.

    Thanks!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •