SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Dec 2001
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    php or apache server config issue

    Hello,

    i have recently set up a local server with php and mysql in order to more efficiently design and test my scripts before uploading to my website.

    i have got most of the configuration set up and found it fairly straightforward and easy to configure but a couple of differences cause my localhost configuration to not pull or display certain php scripts correctly using SSI, in contrast to how they appear on my normal website.

    i am attaching a couple of pics of the output via IE6 to show the differences.

    this is my main page, there are 3 scripts that display incorrectly when showing on localhost.

    1. the random lyrics script is a preconfigured one that i did not write that was made for random images. it basically pulls random lines of html from a text file. i have verified that the php file itself works on localhost when called directly, it just doesn't work for the include.

    2. the q&a script is one i wrote that is basically a modification of my mail script which is used for the ':mail' link and ':problems?' link and they both work fine on localhost when called directly, as does the q&a script itself but when called into the main page as an include, it displays like in the file.

    3. there is also a polling script "Advanced Poll 1.61" that i didn't write that doesn't show up at all with an include but called directly give a scripting error that appears to be cookie related.

    another thing i should note is that i've had issues with cookies for localhost that are probably related somehow to the server config. pages that require a cookie set for password validation will ask me to log in again within a relatively short period of time. this may be related to the issue with the poll but shouldn't have any bearing on the other two scripts. none of these scripts use mysql. as far as i can tell, all scripts using mysql are working fine. i'm running php 4.2.3 on apache server v. 2.0.40 on winXP.

    Any suggestions at config settings i can look at?
    Last edited by SpittingAngels; Oct 16, 2002 at 18:15.

  2. #2
    SitePoint Member
    Join Date
    Dec 2001
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    here is the screenshot for the page as it shows on the hosted website:
    Attached Images Attached Images

  3. #3
    SitePoint Member
    Join Date
    Dec 2001
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    here is the screenshot for the page how it appears when called from localhost:
    Attached Images Attached Images

  4. #4
    SitePoint Member
    Join Date
    Dec 2001
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    UPDATE: i made a duplicate of the page and starting with the php news script , i started taking out the includes and found that the page will only display one php script on the page at a time using includes.

    there are five includes. the header is an include, then the news, then the random lyrics, then the q&a, then the poll.

    so, it appears to be a limitation on how many php includes can be shown on the page.

    if i randomly remove the includes, regardless of which ones are left, the first php script is the only one to display.

    how do i fix this?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •