SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Location
    Hull, UK
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Internet explorer not displaying transparent repeated image correctly

    Hey,

    I have a div that is using a 1x1px transparent red png image to fill the background. Everything seems to be working fine except for in surprise surprise, Internet Explorer (8). Instead of repeating the image it's going off like a gradient. The page in question can be seen here:
    http://cms1.adir.hull.ac.uk/pws4/Fil...ite/index.html

    ieIssues.jpg

    I created a sample page with a div utilising the same method and IE rendered it correctly, so I'm pretty stumped now. Any ideas?

    Many thanks

    Jonno

  2. #2
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Your server seems to be down at present.

    One tip though: repeating a 1px image thousands or millions of times is taxing on the browser. Use a larger one of, say, 20px. The file size is not going to be much different. For example, a 1x1px transparent png would be around 110 bytes and a 100x100px 264 bytes.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jul 2011
    Location
    Hull, UK
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh right I didn't know that! I thought it was more efficient to do it the repeating way! Thanks for the tip

  4. #4
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Slight misunderstanding. Repeat by all means, but use a larger repeating image.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •