SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    Your daddy. WALoeIII's Avatar
    Join Date
    Apr 2001
    Location
    USA
    Posts
    526
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help with Apache

    I just had my server formatted and had a blank installation of Red Hat 7.3. Apache is installed but not running. Here is the problem. I know how to edit the httpd.conf file, and add virtualhosts, but I cannot figure out how to get httpd to run or to startup when I boot. I am using webmin to help me manage my server, but when I try to start httpd from webmin I just get that it didn't work. How can I get some diagnostic information, and figure out why my webserver won't boot.

  2. #2
    SitePoint Member
    Join Date
    Jun 2001
    Location
    Revere, Ma
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Login as root and run this command.

    # /apache/sbin/apachectl start

    Apache should give you the the following

    httpd restarted

    Sarah

  3. #3
    SitePoint Wizard silver trophy
    beley's Avatar
    Join Date
    May 2001
    Location
    LaGrange, Georgia
    Posts
    6,117
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    I just type one of the following commands... RedHat 7.2

    service httpd start
    service httpd stop
    service httpd restart
    service httpd status

    It works with other services as well, including mysqld, sshd, etc.

  4. #4
    Your daddy. WALoeIII's Avatar
    Join Date
    Apr 2001
    Location
    USA
    Posts
    526
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Waht does this mean???
    Code:
    [root@andrewloe root]# service httpd start
    Starting httpd:                                            [  OK  ]
    [root@andrewloe root]# service httpd restart
    Stopping httpd:                                            [FAILED]
    Starting httpd:                                            [  OK  ]
    [root@andrewloe root]# service httpd status
    httpd dead but subsys locked

  5. #5
    Your daddy. WALoeIII's Avatar
    Join Date
    Apr 2001
    Location
    USA
    Posts
    526
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It says its running, but then its not at the same time?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •