SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Glitch on mouseover image help

    Hi

    I have made some mouseover elements on this site, but some of them seem glitchy when you mouseover them. I thought it was a cache problem, but not sure anymore. Does anyone have any ideas?

    http://www.chrisdrogaris.com/hexagram/11/

    Thanks,
    Chris

  2. #2
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Also, I noticed it doesn't work in IE or Safari.
    Any suggestions would be appreciated.

  3. #3
    Non-Member
    Join Date
    Apr 2011
    Location
    no fixed address
    Posts
    851
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You have W3C validation errors in your html. Perhaps fix those first.

    Also, some people don't click posted links, so you might improve your chances of getting help if you post your html and javascript and/or css.

  4. #4
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I fixed the errors and put the site here:
    www.chrisdrogaris.com/hexagram/12/

    Now it just doesn't work in IE, for example if you mouseover the facebook icon it will make a sound.
    There is an IE error in the javascript (bold below):

    Any ideas?

    var Kinetic_2d = function(canvasId){
    this.canvas = document.getElementById(canvasId);
    this.context = this.canvas.getContext("2d");
    this.drawStage = undefined;
    this.listening = false;

  5. #5
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can send someone 10$ in paypal if they can find the problem pm me I guess if anything or post here

  6. #6
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,151
    Mentioned
    262 Post(s)
    Tagged
    5 Thread(s)
    You might want to ask for the thread to be moved to the Javascript forum.

  7. #7
    Mazel tov! bronze trophy kohoutek's Avatar
    Join Date
    Aug 2004
    Location
    Hamburg, Germany
    Posts
    4,248
    Mentioned
    30 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by TechnoBear View Post
    You might want to ask for the thread to be moved to the Javascript forum.
    And done.
    Maleika E. A. | Rockatee | Twitter | Dribbble



  8. #8
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks!

  9. #9
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    UPDATE:

    I updated the link to http://www.chrisdrogaris.com/hexagram/15/

    I the only thing left is the flickring, when you mouse over a image. I preloaded the images and it still flickers.

  10. #10
    SitePoint Evangelist
    Join Date
    May 2007
    Location
    Montreal
    Posts
    408
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok I think I fixed it for the most part. Just letting people know so they don't try to fix it. Thanks!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •