SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast murphaloid's Avatar
    Join Date
    Oct 2011
    Posts
    54
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Spaces in text missing!??

    Hello

    Newbie here.

    Just copied a load of text from a pdf document and pasted it into my html document in Text Mate. Only element Ive used is <p>.

    The problem is that the page renders (in all browsers) with almost no spaces in-between the words of text, resulting in one very long word indeed!

    What's happened?

  2. #2
    Life is not a malfunction gold trophysilver trophybronze trophy
    TechnoBear's Avatar
    Join Date
    Jun 2011
    Location
    Argyll, Scotland
    Posts
    6,421
    Mentioned
    273 Post(s)
    Tagged
    5 Thread(s)
    I've never used Text Mate, so I'm guessing here. Do you have an option checked somewhere to strip whitespace? I take it the text looks OK in Text Mate but not in the browser?

  3. #3
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Sounds like you've copied incompatible space characters from the PDF.

    Try replacing them: in TextMate, open the HTML document, select a space between words, copy it, press Apple-F to open the Find window, paste the space character into the Find field, go to the Replace field and press the spacebar to enter a space. Click the Replace All button. View in Web Preview or save and view in a browser.

  4. #4
    SitePoint Enthusiast murphaloid's Avatar
    Join Date
    Oct 2011
    Posts
    54
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Victorinox...youre a genuis! it worked perfectly

    thanks to both of you!

    Cheers


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •