SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    May 2007
    Posts
    33
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Advanced PHP/Linux/SSH question

    I've booted up an instance of a bitnami LAMP stack on the AWS cloud and found myself with the following problem.

    I can easily ssh to other instances using public/private keys. The following works:
    Code:
    bitnami@ip-10-48-126-61:/opt/bitnami/apps/drupal/htdocs$ ssh -v bitnami@176.34.248.84 "ls"
    OpenSSH_5.3p1 Debian-3ubuntu7, OpenSSL 0.9.8k 25 Mar 2009
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 176.34.248.84 [176.34.248.84] port 22.
    debug1: Connection established.
    debug1: identity file /home/bitnami/.ssh/identity type -1
    debug1: identity file /home/bitnami/.ssh/id_rsa type 1
    debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
    debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
    debug1: identity file /home/bitnami/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu6
    debug1: match: OpenSSH_5.3p1 Debian-3ubuntu6 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu7
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '176.34.248.84' is known and matches the RSA host key.
    debug1: Found key in /home/bitnami/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey
    debug1: Next authentication method: publickey
    debug1: Trying private key: /home/bitnami/.ssh/identity
    debug1: Offering public key: /home/bitnami/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: read PEM private key done: type RSA
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    debug1: Sending command: ls
    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
    test
    debug1: channel 0: free: client-session, nchannels 1
    Transferred: sent 2272, received 2280 bytes, in 0.3 seconds
    Bytes per second: sent 7207.8, received 7233.2
    debug1: Exit status 0
    But then I tried exactly the same via php:
    <?php

    echo system('ssh -v bitnami@176.34.248.84 "ls"');
    ?>

    It gave me the following:
    Code:
    bitnami@ip-10-48-126-61:/opt/bitnami/apps/drupal/htdocs$ php test.php
    OpenSSH_5.3p1 Debian-3ubuntu7, OpenSSL 0.9.8r 8 Feb 2011
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 176.34.248.84 [176.34.248.84] port 22.
    debug1: Connection established.
    debug1: identity file /home/bitnami/.ssh/identity type -1
    debug1: identity file /home/bitnami/.ssh/id_rsa type 1
    debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
    debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
    debug1: identity file /home/bitnami/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu6
    debug1: match: OpenSSH_5.3p1 Debian-3ubuntu6 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu7
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: skipped DNS lookup for numerical hostname
    Segmentation fault
    I think that the segmentation fault is a bug in ssh, not in php.

    Notice how the version of ssh differs (0.9.8k vs 0.9.8r). I am puzzled how this is possible. I tried several things such as the 'which' command, printing out all environment variables and much more, but I really don't understand why the version of ssh would be different when starting it from the php parser.

    Then, I tried rsync. It worked on the command line but failed from PHP again with the message:
    rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
    rsync error: error in rsync protocol data stream (code 12) at io.c(601) [Receiver=3.0.7]

    In non-Bitnami stacks it works just fine, even on AWS.

    Can someone give me a suggestion on where to look next?

  2. #2
    SitePoint Guru
    Join Date
    Nov 2003
    Location
    Huntsville AL
    Posts
    689
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    You could try using the full path to ssh
    echo system('/usr/bin/ssh -v bitnami@176.34.248.84 "ls"');


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •