SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot vbthanks's Avatar
    Join Date
    May 2001
    Location
    Sydney
    Posts
    170
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Session prob AFTER query returned

    Hi all,
    I have a script that is mostly working
    Check session, register session, session times-out all working okay. All links and nav work okay and session variable is passed okay on links between pages (In URL).

    AFTER I query the DB (via form and handler) and results are displayed, links lose the session variable. Can anyone help with this please ?

    Mike
    "You know what you know - but that's all you know!"

  2. #2
    SitePoint Guru enygmadae's Avatar
    Join Date
    Sep 2002
    Location
    Dallas, Tx.
    Posts
    795
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    a few questions:
    - do you have register_globals on or off?
    - is the SQL query variable or the result variable named the same as any other session variable?
    - are you sure you're doing a session_start() at the top of *every* page?
    PHP News, Views and Community: http://www.phpdeveloper.org

  3. #3
    SitePoint Zealot vbthanks's Avatar
    Join Date
    May 2001
    Location
    Sydney
    Posts
    170
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the reply enygmadae....
    No to questions 1 and 3, but yes to 2!
    Thankyou!
    Mike
    "You know what you know - but that's all you know!"


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •