SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    May 2005
    Posts
    248
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    issues with content area height when using <p>, <h2> and none of those

    Hi

    I have many problems with how the content area of my site is behaving.

    Brand new at WordPress, I made a theme (so hopefully this is the right location for this question) but am pretty sure this is mostly a CSS problem. There are likely WP related problems with the coding and understanding of all the pieces and parts so any suggestions there would be appreciated.

    When the <div class="content"> has no content in it, the page looks like: http://mmnkltd.com/wordpress/updates/. This is OK except for the little white line at the bottom.

    When there is just an h2 it looks like: http://mmnkltd.com/wordpress/by-laws/. All the background color is missing below the h2.

    When there is content and an h2 it looks like: http://mmnkltd.com/wordpress/board-members/

    When there is just one line of content, it looks like: http://mmnkltd.com/wordpress/covenants/, just like I'd like it to be.

    and finally, when there are two empty paragraphs, it looks like: http://mmnkltd.com/wordpress/community-info/

    I can see that the different elements are making differences but don't understand how to manipulate them all so the pages can have any header and paragraph tags in any combination and order.

    Any help with understanding and fixing would be ever so much appreciated.
    thank you.

  2. #2
    SitePoint Member
    Join Date
    Nov 2011
    Location
    Nepal
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi mario,
    Even i am new to it. But I jst checked and went thru your problem.And MAY BE the problem is with the class "content".
    why have you cald so much of margin from the top for that div??? when u can fix it with "clear:both" attribute.Lemme know if I am wrong.
    Also I can see the div named "entry" what is that for??? and i guess it is taking auto height which is adding extra height to the content area.

  3. #3
    SitePoint Member
    Join Date
    Nov 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi marioo,

    Your problem is that you have a min-height set on the .content p but not on the .content div. Therefore, the containing div will not expand its height unless there is a <p> in the content. Move the "min-height: 250px" from .content p to .content instead and all your issues should be fixed.

  4. #4
    SitePoint Member
    Join Date
    Nov 2011
    Location
    Nepal
    Posts
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes exactly.I agree with Kmaida..

  5. #5
    SitePoint Addict
    Join Date
    May 2005
    Posts
    248
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    good morning,
    Thank you -- changing the min-height to the content seems to have worked really well (duh', one of those things I really should have known the min-height shouldn't be applied to.) Also I can see the div named
    "...'entry' what is that for??? and i guess it is taking auto height which is adding extra height to the content area."
    I'm pretty sure it's a WP leftover. I am new at what to leave in and drop out especially when it has some PHP code attached to it. I'm such a newbie at that part of it.
    Thanks again


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •