I inherited an old site which I was asked to move to Wordpress, but DO NOTHING MORE. Unfortunately, the JS, as it is, fails in IE 9. If you navigate to these pages:

www.supportliberia.com/home/our-network/philanthropic-partners
www.supportliberia.com/home/resources/projects
www.supportliberia.com/home/resources/ngos

You'll see dynamically loaded Mootools Accordion elements. It works in every browser I've tried except IE 9, including older versions of IE. From what I gather, the effect runs an older version of Mootools 1.2 with an older version of a plugin called Accordion (pre Mootools More). I'm going to keep messing with this, and I may rip it all out and start over with a newer version of Mootools, which is compatible, but I'm pretty much at a dead end. Also a JS noob.

Any help appreciated. TIA.