SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Spacing Issue - another confusing problem

    Hello again,

    I am having quite an annoying issue with a plug in I am using for a wordpress site I am working on.

    http://mgdesign.hostultra.com/WP_Experiment/

    on the left side I am using a plug in called "utech-latest-posts". This plug in will pull in the latest news to the side. There is no style sheet for this and I have tried to style the list to allow for bottom spacing margins.

    However, nothing I try seems to respond and it doesnt space out.. I can do small edits such as alter padding and link colour properties, but not spacing.

    Any ideas why?

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,199
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    I don't see anything there on the left side. There is just an almost empty Facebook box.

  3. #3
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you not see the box above the Facebook side box, latest news? :/

    There should be 5 links there, all clumped together. There are for me on iPhone and other machines

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,199
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Ah yes, I see that. You just didn't make it clear that this was the bit you were referring to.

    There is a style sheet for that, located here:

    http://mgdesign.hostultra.com/WP_Exp...nt_2/style.css

  5. #5
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes thats the main stylesheet... I have added code in there to try and alter the spacing, nothing responds.

    I can alter the background and hover that's about it. when I try to stick space on between links they all stay together

  6. #6
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,367
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Just add some css to move then down.
    Code:
    .utech-latest-posts li{margin-bottom:10px}

  7. #7
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've already tried that in a few different ways. Doesn't work :/
    uploaded it now anyway.

    I think it must be with the plugin being on its own, it's just one php file with no CSS

  8. #8
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,367
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by Zapppa View Post
    I've already tried that in a few different ways. Doesn't work :/
    uploaded it now anyway.
    My code always works I never give out code that hasn't been tried and tested. The above code works fine and is working now on your live site using firebug so I know it works.

    Either we are talking about different things or you have implemented the code incorrectly.

    If you want a margin bottom on the list elements in that box then the code I have given is correct and working. Just add it to your css file and upload it. If it isn't working when added to your css file then we can address the problem once I see the code in your file.

  9. #9
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's in my code @ line 169

  10. #10
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sorry man it works I have absolutely no idea why it wouldn't work for me there.

    Legend, cheers!!!


  11. #11
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,367
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Quote Originally Posted by Zapppa View Post
    It's in my code @ line 169
    No it's not lol

    Firebug shows the rule as empty which means the property value isn't there or isn't recognised.

    Looking at your actual stylesheet we find this:

    Code:
    .utech-latest-posts ul li {
    	margin-botttom:15px;
    }
    As I said above:
    or you have implemented the code incorrectly
    There is no property margin-botttom: but there is one called margin-bottom.

    Don't worry typos are easily made but try and make a point of validating your code before you go searching for bugs as simple typos trip us all up.

  12. #12
    SitePoint Addict Zapppa's Avatar
    Join Date
    Aug 2009
    Posts
    314
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks man, sloppiness on my behalf.



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •