SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Form Script flawed in IE 7/8/9

    Script that controls the form as seen here. Is flawed in IE 7/8/9 if you skip a form field and want to edit the information you can't instead the cursor moves back and forth between the name field and the address field. Gecko and WebKit browsers don't show any problems.

  2. #2
    SitePoint Evangelist
    Join Date
    Jun 2007
    Location
    North Yorkshire, UK
    Posts
    483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tried the contact form in IE8 and did not experience any problem. Could skip over fields, move to any field I like and edit the contents of fields.

  3. #3
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by PhilipToop View Post
    Tried the contact form in IE8 and did not experience any problem.
    Here's one way to trigger the bug:

    Go to the Message field first and overwrite the default text with less than 10 characters, then click on the Email field. Focus then loops between the two fields, taking control of the browser. Launching another application escapes IE from the loop, or causes it to quit.

  4. #4
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It is flawed in IE7 but it's hard to explain, Victor has explained it maybe better then I.

  5. #5
    Non-Member
    Join Date
    Jan 2008
    Location
    N43 44.4824', W079 13.9408
    Posts
    2,220
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can't be fixed ?

  6. #6
    Sploghm bronze trophy Victorinox's Avatar
    Join Date
    Nov 2008
    Posts
    749
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    The script seems to stem from this post on a thread back in May.

    I've tested the code from that post in IE and found it to cause the same looping problem, but with alerts.

    Either ask the member who supplied the code for assistance or seek an alternative.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •