SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Oct 2007
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Div repeats in ie6!!! Please help

    Hi,

    I have recently got abit carried away developing the website linked below in Safari.
    When I've checked it in ie6 I noticed afew problems.
    Unfortunately what seems to be happening is one of my container divs called #main_content (with dotted green border) is being repeated below itself in ie6.

    Please help if you can.

    Thanks in advance

    Erdy.

    http://www.prideacademy.co.uk/index_host.html

  2. #2
    SitePoint Enthusiast
    Join Date
    Sep 2011
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't have IE, but I think that the problem is related to html comments. Check the following links for more info.

    http://judebert.com/progress/permali...mment-bug.html
    http://www.positioniseverything.net/...haracters.html

  3. #3
    SitePoint Member
    Join Date
    Oct 2007
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've taken them all out and its the same unfortunately!

  4. #4
    SitePoint Enthusiast
    Join Date
    Sep 2011
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As I can see, you have many comments in your code.

  5. #5
    SitePoint Member
    Join Date
    Oct 2007
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Those comments are from a Dreamweaver Template. How many websites have those and work in ie6?
    Surely there is something else wrong here?

  6. #6
    SitePoint Wizard Stomme poes's Avatar
    Join Date
    Aug 2007
    Location
    Netherlands
    Posts
    10,276
    Mentioned
    50 Post(s)
    Tagged
    2 Thread(s)
    Duplicate content bug is caused mostly by two things:

    In IE6 (not sure about IE7?) you can cause them by having a comment coming directly after a float, or a comment in between floats. It has to do with IE confusing comments with real tags.

    For now, remove ALL comments or you'll never know if they were the cause.

    However I've managed to trigger duplicate content bug in IE (6 and 7) by having a setup where I had block elements next to inline or inline-block elements.
    Hm, a shame, I don't seem to have the screenshots on my server anymore. I may make another. But here's what I encountered and how I fixed it.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •