SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Sep 2010
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    basic html troubles

    I'm trying to make my page Title a link to the homepage, rather than have a 'home' link in the navigation bar. But it doesn't link to anything. Here's the html:
    <body>
    <div id="header">
    <div id= "title">
    <ul>
    <li><a href="homepage.html">JOSH A BISHOP</a></li>
    </ul>
    </div> <!--end of title div-->
    <div id="navigation">
    ..and the navigation follows here.
    The 'JOSH A BISHOP' title isn't linking to the homepage file. And the html is correct according to the markup validation site.

  2. #2
    SitePoint Wizard rguy84's Avatar
    Join Date
    Sep 2005
    Location
    Durham, NC
    Posts
    1,659
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    The "homepage" is usually index.html instead of home, try that.
    Ryan B | My Blog | Twitter

  3. #3
    Mouse catcher silver trophy
    Stevie D's Avatar
    Join Date
    Mar 2006
    Location
    Yorkshire, UK
    Posts
    5,838
    Mentioned
    114 Post(s)
    Tagged
    1 Thread(s)
    Is the page you're linking from in the same folder as the home page?
    Is the home page definitely called "homepage.html"?
    Have you definitely uploaded the latest version of the page, and refreshed it in your browser?

  4. #4
    SitePoint Wizard bronze trophy Black Max's Avatar
    Join Date
    Apr 2007
    Posts
    4,029
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by rguy84 View Post
    The "homepage" is usually index.html instead of home, try that.
    RGuy is right, but it won't solve your problem. What it will do is allow you to use this as your URL:

    Code:
    http://www.mysite.com
    as opposed to:

    Code:
    http://www.mysite.com/homepage.html
    Quote Originally Posted by Stevie D View Post
    Is the page you're linking from in the same folder as the home page?
    Is the home page definitely called "homepage.html"?
    Have you definitely uploaded the latest version of the page, and refreshed it in your browser?
    That's the ticket right there. I'm thinking you have a directory structure (folder) issue.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •