SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Rogue style that is NOT in my css!

    Hi,

    I have a very frustrating issue that is driving me round the bend!

    I have a contact form that can be seen here. At the bottom of the form, to the left of where it says *Champs obligatoire, there is a an outlined box which is meant to be the submit button!

    The button has a class of 'submit-btn' on it but for some reason it is picking up another style of 'outline: 1px solid #ff0000' (which I can see using one of the FF add-ons) but I have no idea where this is coming from!

    I've done a search of all my external style sheets and there is nothing with a style value of outline. There is also no inline styling around the button!

    Has anyone come across anything like this before? I'm at a loss as to where to look next!

    Thanks,
    Rachel

  2. #2
    From Italy with love silver trophybronze trophy
    guido2004's Avatar
    Join Date
    Sep 2004
    Posts
    9,509
    Mentioned
    163 Post(s)
    Tagged
    4 Thread(s)
    contactform.css (line 18)
    Code:
    .contactform fieldset select, .contactform fieldset input, .contactform fieldset textarea {
        background: url("/media/54621/contact-bg.gif") repeat-x scroll 0 0 transparent;
        border: 1px solid #CACACA;
        box-shadow: 0 1px 1px #CACACA inset;
    This is what the firebug plugin shows me (amongst other things).

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2009
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've discovered that the issue was due to a <fieldset> with no closing tag. I've removed the tag and the submit button has appeared!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •