SitePoint Sponsor

User Tag List

Results 1 to 2 of 2

Thread: Unexplained Gap

  1. #1
    SitePoint Zealot
    Join Date
    Oct 2010
    Posts
    167
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unexplained Gap

    Hi all,

    Could someone please take a look at the CSS on the following page:

    I've Got Kids | Ask-A-Mum Answers Archive Hello world!

    On the right hand side, you will see a Gap next to the headers in the boxes... I can't figure out why that is there... It isn't there on any other page on the website... Yet I can't see any difference.

    I hope someone can point me in the right direction to trouble shoot this issue.

    Thanks,

  2. #2
    Mouse catcher silver trophy Stevie D's Avatar
    Join Date
    Mar 2006
    Location
    Yorkshire, UK
    Posts
    5,888
    Mentioned
    122 Post(s)
    Tagged
    1 Thread(s)
    It seems to be something to do with the secondary navigation, and the search box etc having to sit below it. That secondary nav doesn't seem to be present on other pages, which is why you're not seeing the same problem.

    And without wanting to sound unduly critical, your code needs a lot of work. As well as the 72 validation errors on that page (including several essential images without alt text, unclosed tags and made-up tags), you've got a severe case of divitis ... what on earth is going on here?
    Code:
    <div class="sidebar2">
    <align="Right">
    <div class="Block">
     <div class="Block-tl"></div>
     <div class="Block-tr"><div></div></div>
     <div class="Block-bl"><div></div></div>
     <div class="Block-br"><div></div></div>
     <div class="Block-tc"><div></div></div>
     <div class="Block-bc"><div></div></div>
     <div class="Block-cl"><div></div></div>
     <div class="Block-cr"><div></div></div>
     <div class="Block-cc"></div>
     <div class="Block-body">
    <div class="BlockHeader">
     <div class="header-tag-icon">
      <div class="BlockHeader-text">Search</div>
     </div>
     <div class="l"></div>
     <div class="r"><div></div></div>
    </div>
    <div class="BlockContentRS">
     <div class="BlockContentRS-body">
    (On another note, you could do with having a look at your hosting setup, because the site is really slow to load – 40 seconds for the first page, on a good connection. A quick fix would be to move all the Javascript links to the very end of the document, rather than having them in the <head>, this means that the page can load first.)


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •