SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Sep 2002
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation connecting to a secured access database with ado and asp

    i have a secured msaccess database that i am trying to connect to through a web page using ado and asp/vbscript.

    this is the error i am getting:

    Cannot start your application. The workgroup information file is missing or opened exclusively by another user.

    here is my connection setup:

    Set conn = Server.CreateObject ("Adodb.Connection")
    ds= Server.MapPath("secured.mdw")
    ds = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & ds & ";Mode=ReadWrite|Share Deny None;Persist Security Info=false"
    conn.Open ds,username

    as of right now there is no password...

    any advice??

  2. #2
    Just Blow It bronze trophy
    DaveMaxwell's Avatar
    Join Date
    Nov 1999
    Location
    Mechanicsburg, PA
    Posts
    7,294
    Mentioned
    123 Post(s)
    Tagged
    1 Thread(s)
    Try removing everything after ds. I don't think that is needed since it's default behaviour.

    Also, make sure you don't have it open in MS Access when you try to access it through the webpage.
    Dave Maxwell - Manage Your Site Team Leader
    My favorite YouTube Video! | Star Wars, Dr Suess Style
    Learn how to be ready for The Forums' Move to Discourse

  3. #3
    SitePoint Member
    Join Date
    Sep 2002
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i took everything off after the ds so now here is my conncection:

    Set conn = Server.CreateObject ("Adodb.Connection")
    ds= Server.MapPath("secured.mdw")
    ds = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & ds
    conn.Open ds,"davissl"

    however, i still get the same error

    access is not open in any context that i am aware of...

    when i secured the database it created:

    secured.mdw
    fieldacc.mdb
    a shortcut to fieldadd.mdb
    fieldacc.bak

    am i even trying to connect to the right file??

  4. #4
    SitePoint Wizard big_al's Avatar
    Join Date
    May 2000
    Location
    Victoria, Australia
    Posts
    1,661
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    [VBS]conn.Open ds,username, ""[/VBS]

    That should work
    .NET Code Monkey


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •