SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2011
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    :hover selector with object/embed

    I'm having a huge issue trying to modify the height of an embeded flash object when you mouse over it. I've tried using CSS :hover and jQuery javascript to accomplish it. The problem is that the browser only detects the mouse being over the <object> or <embed>'s border (assuming it has one) and looses track of the mouse once it is over top the flash element, making this effect near impossible. I hope that somebody here has en explanation for this and hopefully a fix.

    I'm testing this in the Linux version of Firefox 5.0.

  2. #2
    Non-Member bronze trophy
    Join Date
    Nov 2009
    Location
    Keene, NH
    Posts
    3,760
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Uhm... what would you be doing with a flash object where it should be outside it's container? Or am I missing the question entirely.

    Do you have an example page? Almost sounds like you're trying to use flash for navigation -- which is one of the giant "no-no's" in web development...

    but then, if you're using flash for anything more than movies or games, you've already tread into the "this isn't how you build a page" territory... no matter what the flashtards who crap out entire sites built in flash will tell you.

    Do you have an example page we could look at? Without seeing what it is you are actually trying to do anything we tell you here is a wild guess.

  3. #3
    SitePoint Enthusiast
    Join Date
    Aug 2011
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Maybe you misunderstood. Here is the site in question (not mine) which should clarify. Isaac Vail - Composer for Digital Worlds

    At the top there is a flash audio player embeded from soundcloud. It normally has a reduced height, but should expand when you place your mouse over it. It works in google chrome, and I suspect on Windows Firefox. I believe this to be an issue with Linux Firefox, so I have created a mozilla bug report.

  4. #4
    Non-Member bronze trophy
    Join Date
    Nov 2009
    Location
    Keene, NH
    Posts
    3,760
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Ok, yeah. The problem actually lies with the plugin for *nix and how it works. I encountered this one like... four years ago, surprised it's still not fixed... wait, Open Source OS... I'm not surprised at all. Unless it's trendy/flashy or someone sets up a bounty, it will never be fixed.

    The problem is that under X11 the framebuffer for plugins is allocated at a fixed size when you initialize it -- so even of the object or embed tag's block in the browser is enlarged, there's no way for the browser to report that to the plugin in that environment -- it's REALLY stupid. Worse, until you click to activate the plugin, a plugin in that environment cannot have 'focus' -- and when the plugin receives focus, the browser element loses hover and/or focus. Even just mousing over the plugin actually makes the BROWSER lose focus, much less the element itself.

    Part of why X11 implementations still feel like buggy broken toys to me -- and certainly not useful so far as desktop OS use is concerned.

    Just checked, Opera on *nix has the same behavior as does Konqueror, so it's much more likely an issue with how the flash plugin works than with the browsers themselves... Works just fine on Windows and OSX here... Hell, even seems to work in iCab.

  5. #5
    SitePoint Enthusiast
    Join Date
    Aug 2011
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well it does work perfectly well in Chromium, so somebody can apparently do things right.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •