SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Feb 2001
    Location
    Boston
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Client gets redirected back to old IP - rest of the world sees the new IP

    Let me start by saying that I am not a networking expert...

    I have a client who cannot see their new web site. Trying to view the site from anywhere on their network sends them back to their old IP address where they see a confirmation page "you are viewing the old site."

    The client of course was convinced it was something on my end until I told him to take out his phone and try viewing the new site - which he could no problem. Any other computer sitting outside their network can view the site fine.

    This leads me to believe that the DNS has propagated but the client still has some internal settings somewhere that are directing them to the old IP.

    Their set up: 22 sites networked together (they have tried from several sites -all the same which leads me to believe that it is a top-level issue rather than a machine or site issue). Firewall software which they have set to strict filtering standards (it is a school). Websense Triton 2010. They have also specifically unblocked all four IP addresses (two at the old host and two at the new host).

    Networking software - I am still trying to find out but they have a mix of old and new systems. (call in to the admin to get this info).

    The computers are a mix of mostly WinXP with a few Win7 and Macs.

    When they type in domainname.com they get redirected back to the old IP. When they type in www.domainname.com they get a firewall warning message. This is how they have had it set up for years - back when it actually mattered whether you had www. in front of your domain or not. This leads me to believe that it is not the firewall software but rather some company internal network setting.

    I asked them to clear their HOSTS file on a couple of computers and check that, still the same. Again, leads me back to top-level network problem.

    They tell me that they have set up the firewall to configure all the sites as friendly. There has got to be something else at play here.

    Any thoughts?

  2. #2
    Non-Member MyDomAinZ.us's Avatar
    Join Date
    Feb 2008
    Location
    Fort Bregg, North Carolina, USA
    Posts
    798
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Delete all the cookies, catche, history of the browser and restart the computer, then try :-)

  3. #3
    Community Advisor silver trophy

    Join Date
    Nov 2006
    Location
    UK
    Posts
    2,547
    Mentioned
    40 Post(s)
    Tagged
    1 Thread(s)
    Get them to find out whether their network client PCs are getting their DNS from the network server or the ISP. If it's the network server then flush its DNS cache (administrative tools-> DNS snap-in). If the client PCs are getting DNS directly from the ISP then try changing one to e.g google on 8.8.8.8 and 8.8.4.4

  4. #4
    SitePoint Zealot ChrisWiegman's Avatar
    Join Date
    Sep 2010
    Location
    Austin, Texas, United States
    Posts
    177
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like a DNS cache issue. I've seen poorly configured DNS servers cache lookups for weeks beyond the record's expiration. Try setting them up with something like OpenDNS | DNS-Based Web Security and see if that helps.

  5. #5
    Chive On FFCus's Avatar
    Join Date
    Feb 2006
    Location
    Connecticut
    Posts
    542
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have a client that has an internal DNS at their organization. We had the same issue. Their IT dept. had to go an and update the record for the domain name to point to the correct IP. Until they did that, the domain went to the old site internally but the new site for everybody else.

    Do they have an IT dept. that handles their DNS?


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •