Let me start by saying that I am not a networking expert...

I have a client who cannot see their new web site. Trying to view the site from anywhere on their network sends them back to their old IP address where they see a confirmation page "you are viewing the old site."

The client of course was convinced it was something on my end until I told him to take out his phone and try viewing the new site - which he could no problem. Any other computer sitting outside their network can view the site fine.

This leads me to believe that the DNS has propagated but the client still has some internal settings somewhere that are directing them to the old IP.

Their set up: 22 sites networked together (they have tried from several sites -all the same which leads me to believe that it is a top-level issue rather than a machine or site issue). Firewall software which they have set to strict filtering standards (it is a school). Websense Triton 2010. They have also specifically unblocked all four IP addresses (two at the old host and two at the new host).

Networking software - I am still trying to find out but they have a mix of old and new systems. (call in to the admin to get this info).

The computers are a mix of mostly WinXP with a few Win7 and Macs.

When they type in domainname.com they get redirected back to the old IP. When they type in www.domainname.com they get a firewall warning message. This is how they have had it set up for years - back when it actually mattered whether you had www. in front of your domain or not. This leads me to believe that it is not the firewall software but rather some company internal network setting.

I asked them to clear their HOSTS file on a couple of computers and check that, still the same. Again, leads me back to top-level network problem.

They tell me that they have set up the firewall to configure all the sites as friendly. There has got to be something else at play here.

Any thoughts?