SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Addict
    Join Date
    Jul 2009
    Posts
    356
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Menu lines up perfect in firefox, but not ie.

    I know I took a shortcut by making my menu bg part of the entire bg image, and best case would be to make it the bg of the menu, but i digress.

    You will see the outside of my menu buttons are about 2px off vertically when viewing in ie. Can't figure out why really. Any ideas?

    Print - Municipal Resident Directory and Map

    Thanks!

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,324
    Mentioned
    462 Post(s)
    Tagged
    8 Thread(s)
    The menu looks fine in IE9 to me.

  3. #3
    SitePoint Enthusiast
    Join Date
    Nov 2005
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't know the technical reason why this is happening but it is probably something to do with the specific line height being applied the nav elements and IE7 calculating something differently.

    Just whack in some IE7 conditionals and remove 2/3px of the padding/margin as a quick fix.

    Or do it properly with an extra div at the top containing the logo with a min-height declaration which determines where the nav starts.

    good luck

  4. #4
    SitePoint Member
    Join Date
    Nov 2010
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The problem may be that IE 7 and lower positions the dropdown different from other browsers. You may need something like "left:0; topx;" to make the positioning work the same in all browsers.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •