SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Evangelist
    Join Date
    Mar 2011
    Posts
    423
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS Styling problem - copying from software 'Pages'

    I am using software called "Pages" to add CSS code to text. This is then copied and pasted into MySQL.

    The problem is wherever there is a " when it appears online (I am using PHP to display the text) it replaces it with a ? in a black diamond shaped square.

    And the <li> and </li> tags I use work as they should but again it adds a ? after each <li> and </li> when viewed online.

    These problems are only with Safari. It is fine in Internet Explorer. If I manually delete all " and <li></li> and write exactly the same again within PHPMyAdmin then it appears fine online.

    It seems to be a problem with copying from 'Pages'. Is there a better software package I could use for free. Something like notepad in Windows - except i am using a Mac.

    Matt.

  2. #2
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    You'll have a mismatch of encoding between the software you are using you as probably aren't actually copying plain text. What encoding are you using for the webpage?

    You'll be probably seeing 'replacement character' � (often a black diamond with a white question mark) a symbol found in the Unicode standard at codepoint U+FFFD in the Specials table.

  3. #3
    SitePoint Member
    Join Date
    Apr 2011
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Textedit is the mac equivalent. You should have it already...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •