SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict
    Join Date
    Apr 2010
    Posts
    390
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    onclick link without hd works but the with doesnt work

    hi i have the follow jwplayer i've got a link that loads the video into the player fine but now i am trying to add another one that load with the hd option
    here the single one works fine
    Code:
    <a title="Testimonial One" href="#" onclick="loadNplay('http://www.1st4film.biz/homepagefilms/looknorthlunchtime2.mp4')"><img src="images/24hrs.jpg" border="0" title="picture" /></a>
    here the one with hd link that doesnt work any idea how i can fix it?
    Code:
    <a title="Testimonial One" href="#" onclick="loadNplay(
               'http://www.1st4film.biz/homepagefilms/looknorthlunchtime2.mp4',
               'hd.file': 'videos/film.mp4',
               'title': 'Big Buck Bunny Trailer',
               'provder': 'rtmp',
               'streamer': 'rtmp://rtmp.server.com/application',
               'image': 'http://thumbnails.server.com/thumbs/bunny.jpg',
               'duration': '33.03',
               'description': 'An animated short from the Blender project')"><img src="images/24hrs.jpg" border="0" title="picture" /></a>

  2. #2
    SitePoint Evangelist
    Join Date
    Jun 2007
    Location
    North Yorkshire, UK
    Posts
    483
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is loadNplay a function of yours? If so can you post the code.

    If loadNplay is a 3rd party piece of code - Is documentation available?

    It looks to me if the subsequent arguments are an associative array. In which you might just be missing some brackets

    <a title="Testimonial One" href="#" onclick="loadNplay(
    'http://www.1st4film.biz/homepagefilms/looknorthlunchtime2.mp4',
    { 'hd.file': 'videos/film.mp4',
    'title': 'Big Buck Bunny Trailer',
    'provder': 'rtmp',
    'streamer': 'rtmp://rtmp.server.com/application',
    'image': 'http://thumbnails.server.com/thumbs/bunny.jpg',
    'duration': '33.03',
    'description': 'An animated short from the Blender project' })">

  3. #3
    SitePoint Addict
    Join Date
    Apr 2010
    Posts
    390
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi thanks for taking the time to look out my issue i managed to fixed here how is working now

    Code:
    <div id='mediaplayer'></div>
    
    <script type="text/javascript">
      jwplayer('mediaplayer').setup({
        'flashplayer': 'player.swf',
        'id': 'playerID',
        'width': '640',
        'height': '480',
        'playlistsize': '160',
    	'skin': 'modieus.zip',
    	'dock': 'false',
         autostart: true, 
        'plugins': {
           'hd-1': {}
        }
    	
      });
    </script>
    the code to call the to player both video normal and hd
    Code:
    <a href="#" onClick="jwplayer().load({'file': 'hofbell30732_SD.mp4', 'hd.file': 'videos/film.mp4'})">


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •