SitePoint Sponsor

User Tag List

Results 1 to 5 of 5

Thread: Simple Problem

  1. #1
    SitePoint Zealot AirFor's Avatar
    Join Date
    Oct 2010
    Location
    Berrigan, NSW, Australia
    Posts
    132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Simple Problem

    Hi guys and girls,

    So I have a simple problem related to list-style-type property. For some reason when I set a list-style-type to the list at the bottom of my page it does not apply. I'm assuming this is because another rule is over riding the setting but I can't distinguish which.

    Example below:

    Site

  2. #2
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,191
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    In your standard.css you have no selectors referring to the <ol> list in your footer, also you have your reset CSS been imported after the main CSS file. In order for your selectors to work correctly reset.css needs to be imported before standard.css.

  3. #3
    SitePoint Zealot AirFor's Avatar
    Join Date
    Oct 2010
    Location
    Berrigan, NSW, Australia
    Posts
    132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ah yes, I took it out as I was trying to work out why the selector was not working.

    I should be able to put (keeping in mind I changed ol to ul)
    Code:
    .rightcol ul {
    list-style-type: square;
    }
    Or not?

    I didn't know that you needed the reset.css to be imported first, thank you for letting me know.

  4. #4
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,191
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Try this

    Code CSS:
    .rightcol ul {
        list-style-type: square;
        margin-left: 42px;
    }

  5. #5
    SitePoint Zealot AirFor's Avatar
    Join Date
    Oct 2010
    Location
    Berrigan, NSW, Australia
    Posts
    132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ace, thank you. I was thinking that the bullets may have been hidden originally. Thanks for your help mate.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •