Salutations everyone,

Here is the deal; I've developed a full-scale YouTube API interface for a client's website. This interface parses a feed and displays linked thumbnails which play the videos within a shadowbox on the webpage. This module is designed for use within Joomla 1.6 CMS.
This complicates things slightly in a few ways; for instance: if I have a video list in the main content pane, a sect of the module which has been separated into another area like the right hand bar for example cannot directly communicate with the content pane module.
I've developed a search module that contains a search field/button as well as a long list of available filters based on a series of keywords.
I've gotten around the communication issues between these two module sects by appending the url with a hash whose value reflects the filter or searched term which the main video list listens for via onhashchange methods.

My client wants the categories of the filters to display as well as the filter text on a bar below it. No problem.
The conflict starts here;
He also wants it to have a different title and say Custom search on the bar below it when a custom value has been searched. On top of that when the video list is constructed for the first time and it displays the whole video list he wants it to say All and then "all videos" on the bar below it... Doesn't sound like a big deal and I didn't think it was because my method worked perfectly offline during dev. However the way I decide to play all videos is based on the absence of a hash filter. I simply check if the searchterm equals '' like this..
Code:
if (get_searchedterm() != ' ') {than check hash against filters}
else {if (get_searchedterm() == ' ') {than display title, bar, and all videos} else {display the custom search options}}
note: i'm not using a space between the apostrophes
The problem with this is... my get method/variable never comes back ON the server... I've tried just about everything and I believe it has something to do with Joomla modifying the url in some way or something...Now I don't see that the order matters really except to optimize the process speed. So I started debugging this issue and placed just above the checks an alert will display blank just the same as it would if it contained
Code:
' '
but doesn't match up... I've tried using null, undefined, etc with no luck.

Would anyone happen to have a good idea for an alternative approach or perhaps an explanation of what ' ' means exactly in javascript and why I wouldn't be able to match it to the blank alert box visible in debugging methods?
Perhaps some sort of boolean switch method might work for finding out if all videos are displaying but remember that the module sector displaying the videos and the search module can't easily communicate directly.

Any ideas or requests for elaboration are welcome.
I don't dare post the code because it as LOT to look at (500+ non-spaced lines ATM...)