SitePoint Sponsor

User Tag List

Results 1 to 22 of 22
  1. #1
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)

    Link to anchor doesn't seem to be working in FF4 or FF5

    Hi,

    When I open the following link in IE, Opera, Safari or Chrome, it works as it should. The content which follows the anchor tag (<a name="neuro">) in the source code, is displayed at the top of the viewport.

    www.rd.ruhr-uni-bochum.de/filme.html#neuro

    However, when I open the same link in Firefox 4 or Firefox 5, the browser jumps straight to the bottom of the page, not to the anchor tag.

    I've looked at the source code of the above page and the anchor seems to be specified correctly. There is only this one anchor element with a name of "neuro" and there are no other tags on the page with this name, id or class.

    Does anyone have a clue as to why FF4 and FF5 are doing this?
    FF3 worked as it should.

    Thanks in advance.

  2. #2
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    It works correctly for me albeit you do have a lot of markup errors in that page and it would have been preferable to use ID rather than the name attribute. Did you mean to place a 'fragment identifier' for the actual h3 rather than above the mp4?

  3. #3
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    It's not my page dude. I just want to link to it.
    It's full of markup errors and the code is horrible - no question, but I can't do anything about that.

    But do I understand correctly, that when you click on the above link in FF4 or FF5, the window that opens looks like the image below?


  4. #4
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Yes, that is where it is supposed to link to according to the markup and that's where Fx does take me when I click on the above link (I land at same place as seen in that JPG).

  5. #5
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    Sorry to be persistent, but which Firefox version are you using?

    I have tried FF4 at work and FF4 + 5 at home on multiple computers and when I click on the above link I see what's in the jpeg below.

    This is the bottom of the page.

    Could anyone else with Firefox 4 or 5 try this out for me?


  6. #6
    bronze trophy
    Join Date
    Dec 2004
    Location
    Sweden
    Posts
    2,670
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Works for me with Nightly on mac. But you could file a bug anyway. I suspect it could have to do with the page being rendered without styles the first time, then Firefox jumps to the anchor, then the styles are applied and Firefox doesn't update the scroll position, or something (I saw a flash of unstyled content first time but the scroll position was correct anyway).
    Simon Pieters

  7. #7
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    Thanks for the replies.
    Could anyone else confirm if they are seeing the same thing in FF4 or FF5 (i.e. the bottom of the page instead of the anchor) and if they think it is a bug.

  8. #8
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,168
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    Yeah, I see the bottom of the screen in FF4 PC.

  9. #9
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    Cheers Ralph, do you think this is a bug?
    If so, how does one go about reporting it?

  10. #10
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,168
    Mentioned
    454 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by Pullo View Post
    Cheers Ralph, do you think this is a bug?
    If so, how does one go about reporting it?
    Normally such links work fine in FF4 and presumably 5 (I just did a test to convince myself) so I'd say it's something to do with the bad coding of that page, as others have suggested.

  11. #11
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Well, it seems to be fifty-fifty at the moment; it worked for me and Simon but not for yourself and Ralph.

  12. #12
    bronze trophy
    Join Date
    Dec 2004
    Location
    Sweden
    Posts
    2,670
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ralph.m View Post
    Normally such links work fine in FF4 and presumably 5 (I just did a test to convince myself) so I'd say it's something to do with the bad coding of that page, as others have suggested.
    Sure, but it should still work. File a bug here https://bugzilla.mozilla.org/enter_b...h=dupes%7CCore
    Simon Pieters

  13. #13
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    As Simon is on a Mac, it might be a PC thing.
    This is getting interesting.

    Robert, are you on a PC or a Mac? Which FF version are you using?
    Cheers.

  14. #14
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Fx 5.x PC.

  15. #15
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    I filed a bug as Simon suggested.
    Let's see what happens.
    Thanks for the help so far.

  16. #16
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    Just a quick update:

    The guys over at Bugzilla seem to agree that this is undesired behaviour on FF's part. I don't know what kind of importance they will give to fixing this, but it is good to know that it is not something wrong with the original web page.

    Someone also pointed out that in about:config, setting "html5.parser.enable" to "false", makes this go away.

    Could this be the reason that you are seeing correct behaviour Robert?

  17. #17
    bronze trophy
    Join Date
    Dec 2004
    Location
    Sweden
    Posts
    2,670
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Pullo View Post
    Someone also pointed out that in about:config, setting "html5.parser.enable" to "false", makes this go away.
    Interesting!

    What's the bug number?
    Simon Pieters

  18. #18
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)

  19. #19
    Robert Wellock silver trophybronze trophy xhtmlcoder's Avatar
    Join Date
    Apr 2002
    Location
    A Maze of Twisty Little Passages
    Posts
    6,316
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    I have html5.parser.enable as true I don't alter the config as a general rule. Although I typically surf without JS but I doubt that would alter the results.

  20. #20
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,347
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    The problem in the site linked to seems to be caused by this strange tag in the head combined with the imported css files.

    Code:
    <imp:live-info sysid="2517d20c-54d1-18b6-6e03-c6f99a666cba" node_id="/1/849" />
    If that line is removed then the page works correctly.

  21. #21
    Gre aus'm Pott gold trophysilver trophybronze trophy
    Pullo's Avatar
    Join Date
    Jun 2007
    Location
    Germany
    Posts
    5,938
    Mentioned
    214 Post(s)
    Tagged
    12 Thread(s)
    The strange tag comes from the page being made with the Imperia CMS.

    Imperia inserts this tag into all of the pages it makes, as it also offers a browser extension, which by means of these tags, enables a one-click edit of any specific page.

    It's a bit weird though, isn't it, that all other Browsers jump to the anchor tag when the link is clicked, just not FF4 and FF5.

  22. #22
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,347
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Well its obviously some sort of bug but in testing just removing that tag fixes the problem and of course that tag is invalid and if the code is invalid then all bets are off anyway.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •