SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Apr 2007
    Posts
    69
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Simple question about Sessions

    I use session_start(); and then $_SESSION['uid] = .. in order
    to set up sessions in the index.php page.
    but when i am sending an ajax request to a different page
    in which i have to get that session uid, it does not work for some people.
    it works for me and a few more people, but it doesb't work for others.
    I'm guessing i am doing something wrong but i am just calling session_start()
    before using $_SESSION['uid'] to get the value of it.

    would love to get some help with this one. thank you

  2. #2
    SitePoint Wizard bronze trophy chris.upjohn's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, AU
    Posts
    2,191
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    I have had this issue with AJAX as well and strangely enough i solved it by moving session_start() to be within the actual function i was calling which actually someone worked. I'm probably not much help but its worth a try to just shift it around and get your users to keep testing it.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jun 2009
    Location
    Kolkata, India
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check with your users if they have javascript enabled on browser or not, I mean, the AJAX at all runs from their browser or not...
    $0.50/Mo for 500MB Web hosting Kolkata
    Web design in Kolkata
    Website development company in Kolkata

    Hostgator 25% Discount Coupon wow25percent


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •