SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict Evan2all's Avatar
    Join Date
    Sep 2004
    Location
    Dhaka, Bangladesh
    Posts
    201
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Navigation problem on IE

    Hi,

    Please have a look at this website first: Baby Blog and Resource Centre - Hello Baby Online Nursery shop, London UK

    You will see on FF and Chrome the navigation is working fine but on IE navigation tabs on top are jumping ..... I think hover position is not working properly....

    I really tried my best to find out the solution to fix it for IE but failed. What is actually going on?

    Please help. Im working on this for so many days but not getting any result. But frustrated by now. Can you advice what really is happening on IE in this case?
    Shajed Zaman
    Web 2.0 holic, Small Business Website Designer, Pro Blogger
    SME DEVELOPERS, creative design solution|
    I AM WEBSITE DEVELOPER|Twitt Me

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,355
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    It actually looks ok to me in IE8 but jumps in Firefox 4?

    The problem is that you have a fixed pixel width image and yopu are positioning the hover on top of the image using ems which are a rounded measurement and will vary with browers and font-size.

    use pixels when you have a fixed width to work with.

    Make these changes:

    Code:
    #branding #header-menu{left:0}/* ie7 and under need co-ordinates*/
    #header-menu .header-menu-tabs #header-menu-ul-left {
      display: inline;/* double margin bug fix*/
      float: left;
      list-style: none ;
      margin:0 0 0 16px;/* exact measurement needed */
      position: relative;
    }

  3. #3
    SitePoint Addict Evan2all's Avatar
    Join Date
    Sep 2004
    Location
    Dhaka, Bangladesh
    Posts
    201
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Paul,

    I think it is working on IE 8 and as well as on firefox. A big thanks to you mate. THANK YOU!
    Shajed Zaman
    Web 2.0 holic, Small Business Website Designer, Pro Blogger
    SME DEVELOPERS, creative design solution|
    I AM WEBSITE DEVELOPER|Twitt Me


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •