SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE 7 Navigation Problems

    Hello,

    I'm transferring a site over to wordpress and I'm having ie7 problems with the navigation. It works everywhere else. I'm not quite sure how to fix it. I'm not sure if wordpress is adding styles and stuff to mess it up because the non-wordpress version of the site works fine and I pretty much used the styles they had.

    Site is still in progress. Just trying to get the header going.

    Mixers Lounge | Just another WordPress site

    Any ideas?

    Thanks so much!
    Daniel

  2. #2
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    43
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by halestorm View Post
    Hello,

    I'm transferring a site over to wordpress and I'm having ie7 problems with the navigation. It works everywhere else. I'm not quite sure how to fix it. I'm not sure if wordpress is adding styles and stuff to mess it up because the non-wordpress version of the site works fine and I pretty much used the styles they had.

    Site is still in progress. Just trying to get the header going.

    Mixers Lounge | Just another WordPress site

    Any ideas?

    Thanks so much!
    Daniel
    - I'd specify widths in the li's since IE7 is probably thinking that they don't exist now. This will give IE 7 something definite to work with probably.
    Kevin(vs.net) Kelly
    http://kevinvs.net

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,367
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Don't specify a width on the anchors or list but make sure the main parent has a width.

    e.g.
    Code:
    *+html #navArea_1{width:675px}/* ie7*/
    * html #navArea_1{width:675px}/* ie6*/
    That seems to fix it although you seem to have several levels of nestings that aren't used there.

  4. #4
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks so much!

  5. #5
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi I'm back.

    Yes the navigation is working but some pages are not loading at all. One of the pages is the About page.

    http://www.tamismightinteriors.com/dev/about

    Page just won't load. IE7 only. Any ideas?

  6. #6
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,367
    Mentioned
    180 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    You can't really add position:relative to elements in IE7 unless you also give them haslayout as they become unreliable.

    This should do the trick.
    Code:
    #main_inner{zoom:1.0}

  7. #7
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Sorry I posed in the wrong thread. I just want to confirm that the change you suggest is for ie7.css That's where it was last time...

  8. #8
    SitePoint Enthusiast
    Join Date
    Mar 2010
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Never mind. I stuck it in and it works! Thanks again for your help


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •