SitePoint Sponsor

User Tag List

Results 1 to 8 of 8
  1. #1
    SitePoint Guru
    Join Date
    Aug 2009
    Posts
    641
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    My black BG behind my menu disappeared

    Hi Guys,

    Having some trouble, not sure why my black background on the top-bar div just disappeared in this one part of the site.

    Newsroom The Club – Thunder Bay Country Club

    Its not there but is on the homepage of the site....

    The Club – Thunder Bay Country Club

    Any ideas why it disappeared?

    Thanks,

    Mike

  2. #2
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,197
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    You've got two background images sitting over the top of it:

    firstly

    Code:
    #wrapper {
      background: url("images/wrapper-bg.png") repeat-y scroll center top transparent;
      margin: -65px auto auto;
      min-height: 100%;
      overflow: hidden;
      width: 725px;
    }
    then

    Code:
    #content-bar {
      background: url("images/bg.jpg") no-repeat fixed center top transparent;
      border-bottom: 40px solid #006C67;
      height: 100px;
    }
    A quick fix would be to replace that second background image with an image that is black at the top (to match the black band) with some blue underneath.

  3. #3
    SitePoint Guru
    Join Date
    Aug 2009
    Posts
    641
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hmmm that could work but this was working fine before and now all of a sudden it is not.

  4. #4
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,197
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Quote Originally Posted by mbond5 View Post
    Hmmm that could work but this was working fine before and now all of a sudden it is not.
    It didn't just suddenly happen, though. You have deliberately placed two images over the top of the black background, so there is nothing unexpected here.

  5. #5
    SitePoint Guru
    Join Date
    Aug 2009
    Posts
    641
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    But the black bar shows up other places and before it didnt look like this so I must have done something wrong...

    Look here I had it fine but when I moved it over, I may hav not copied something correctly that I'm missing....

    The Club - Thunder Bay Country Club

    Above its fine but below it is not....

    Newsroom The Club – Thunder Bay Country Club

  6. #6
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,197
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    The HTML is different on those two pages—a quick look should show you that. In the page that's working, you have a header div wrapped around the top-bar and logo, and it has a z-index that lifts it above the wrapper div. On the second page, that header div is missing.

    Code:
    <div id="header">
        <div id="top-bar">
        </div>
        <div id="logo">  
        </div>
    </div>

  7. #7
    SitePoint Guru
    Join Date
    Aug 2009
    Posts
    641
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Ahhh yes your right I forgot to copy the over... Now it works

  8. #8
    It's all Geek to me silver trophybronze trophy
    ralph.m's Avatar
    Join Date
    Mar 2009
    Location
    Melbourne, AU
    Posts
    24,197
    Mentioned
    456 Post(s)
    Tagged
    8 Thread(s)
    Another pair of eyes never hurts.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •