Hello all,

Was wanting to see if I could get some advice / help (if anyone here is familiar) with the Compass CSS framework and how to install it. I'm running OSX 10.6.7 and have ruby 1.8.7 installed, however, when I type:


Code:
$ gem update --system
$ gem install compass
per the instructions and after setting up rvm with the help of this link, I get the message:


Code:
$ gem install compass
[/Library/Ruby/Gems/1.8/specifications/builder-2.1.2.gemspec] isn't a Gem::Specification (NilClass instead).
/Library/Ruby/Site/1.8/rubygems/specification.rb:277:in `_resort!': undefined method `name' for nil:NilClass (NoMethodError)
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:276:in `sort!'
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:276:in `_resort!'
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:270:in `_all'
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:402:in `each'
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:434:in `find'
	from /Library/Ruby/Site/1.8/rubygems/specification.rb:434:in `find_by_path'
	from /Library/Ruby/Site/1.8/rubygems.rb:205:in `try_activate'
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:58:in `require'
	from /Library/Ruby/Site/1.8/rubygems/config_file.rb:55
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in `require'
	from /Library/Ruby/Site/1.8/rubygems/gem_runner.rb:9
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in `require'
	from /usr/bin/gem:9
Have no idea what I'm doing wrong. Even purchased the GUI app for compass and the program will not open. Any help is appreciated. Thanks!