SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Addict tlacaelelrl's Avatar
    Join Date
    Apr 2011
    Location
    Mexico city, Mexico
    Posts
    353
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    style works in firefox correctly but...

    I am working with a side tab, trying now for many hours to make it work and finally I was able to, so happy I went to test in IE to find out that it does not work properly, this page when oppened in firefox you can see a tab that says "This text" on the right top, and it is doing exactly what I want it to, it is possitioned -45px off the right, but this does not work the same in IE as it needs -90px.

    There is also another issue, if you hover while on firefox you can place the mouse all along the tab and it will hover correctly however in IE the hover does work but only on the bottom half of the tab, if you go to the top half then it does not do anything.

    Can someone help me out on this, is there an easy way to add browser specific style or something else I could do? because if I fix IE then FF stops working, and I havebīt even checked in other browsers

  2. #2
    SitePoint Addict tlacaelelrl's Avatar
    Join Date
    Apr 2011
    Location
    Mexico city, Mexico
    Posts
    353
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I just found this

    -moz-initial;

    well, that takes care of one problem, the tab is now placed in IE at the correct place, however the hover effect still, is taking effect only at the half bottom portion of the tab so, if anyone has a solution for me on this I will be waiting...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •