SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    May 2002
    Location
    Annapolis, Md
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Strange IE problem, Images won't display depending on URL

    Ok this one has me stumped. I'm currently working on a web site that uses mostly CSS and a few images and backgrounds.

    http://www.dave.griffith.name (Yes I was the only person who actually purchased a .name)


    The problem is that if I type the URL into the address bar of the browser as: http://www.dave.griffith.name/ then all images are displayed correctly.
    However, if I type http://www.dave.griffith.name and leave off the trailing slash, the images don't load in IE. Mozilla actually will add the training slash and proceed to load the images but IE will not.

    What is strange is that I know this is not a simple invalid image src location.

    I have never seen nor heard of this problem in my short 4 years of web design. I'm hoping it is something simple or a stupid oversight on my part or possibly an issue to take up with my host. Who knows?

    Anyone have any ideas??

  2. #2
    Drupaler bronze trophy greg.harvey's Avatar
    Join Date
    Jul 2002
    Location
    London, UK
    Posts
    3,258
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The problem is this. Here's one of your image tags:

    Code:
    <img src="/images/linkbullet.gif" width="8" height="12">
    It's a hunch, granted, but I reckon that if you replace that with this (not the removal of the first 'slash') ...

    Code:
    <img src="images/linkbullet.gif" width="8" height="12">
    ... all will be fine.

    G

    Ps -- I've had similar probs before. Don't know what causes it, but I'm sure someone who knows the techy stuff better than me will fill us both in there.

  3. #3
    SitePoint Member
    Join Date
    May 2002
    Location
    Annapolis, Md
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the response...

    I was typing a reply just now when the source of the problem occured to me.

    First let me quote myself:

    I'm hoping it is something simple or a stupid oversight on my part
    Well guess what? It was. I had enabled a "hotlink prevention" feature from my host to stop images being linked from outside websites and didn't quite configure it right.

    You win some you lose some. Chalk this one up in the L column...

  4. #4
    SitePoint Enthusiast
    Join Date
    Jun 2001
    Location
    nc, for now.
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hey, at least you know that your hotlink protection was working.

    It could be worse.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •