I can't seem to find a straight answer to this so am asking here in the hopes someone may know. Is Google maps v2 only compatible with IE8 via forcing it into IE7 compatibility mode? I manage several sites that work fine with v2 on ALL browsers except IE8 (probably IE9, f**k IE) and I would appreciate an answer. I just learned about this today, I just don't understand how the hell something can work on the piles of trash that are IE6 and IE7 yet not work on IE8, its mind boggling.

Thanks