SitePoint Sponsor

User Tag List

Results 1 to 4 of 4

Thread: RSS not working

  1. #1
    SitePoint Wizard nofel's Avatar
    Join Date
    Aug 2007
    Location
    Earth
    Posts
    1,766
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    RSS not working

    hi folks,
    i created a RSS. i am new at it and using it on my worpress. i tried couple of other RSS it work but i get this php error for my RSS
    Code PHP:
    [B]Warning[/B]:  Invalid argument supplied for foreach() in [B]C:\xampp\htdocs\wordpress\wp-content\plugins\rss-stream\rss-stream.php[/B] on line
    and my xml is as follow
    Code XML:
    <?xml version="1.0" encoding="utf-8"?>
    <rss version="2.0">
    <channel>
        <item>
        <title>Aligning</title>
            <description> Strategic Change Mentor</description>
                <link></link>    
        </item>
                    <item>
                        <title>Expertise</title>
                                <description>“waking up in the middle of one night in 2008.</description>
                                    <link></link>
        </item>
    </channel>
    </rss>
    where am i going wrong? why isn't it showing up and error shows up
    All those who wander aren't lost.

  2. #2
    SitePoint Evangelist speda1's Avatar
    Join Date
    Jan 2002
    Posts
    550
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like you are trying to loop through an empty array.

  3. #3
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,191
    Mentioned
    191 Post(s)
    Tagged
    2 Thread(s)
    That's an open-source plugin and I've downloaded it. It has several "foreach"s and you left out the line number

    If you say what that is I'll be glad to help by walking you through debugging.

  4. #4
    SitePoint Wizard nofel's Avatar
    Join Date
    Aug 2007
    Location
    Earth
    Posts
    1,766
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    i have noticed that my rss that i created isn't picked up by these plug in. i wonder what is wrong?
    All those who wander aren't lost.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •