SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    I believe you have my stapler. scrubz's Avatar
    Join Date
    Feb 2001
    Location
    Van down by the river
    Posts
    254
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    MS Access: Problem with default value

    I'm trying to use a default value in an MS Access field that adds 1000 to the orderID field. So, the default value would be... =[orderID]+1000

    But I get an error that "the database engine does not recognize either the 'orderID' in a validation expression, or the default value in the table CUSTOMER."

    As far as I can tell, the syntax is correct. What am I missing?

  2. #2
    SitePoint Evangelist compwizard's Avatar
    Join Date
    May 2002
    Location
    United States
    Posts
    457
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't think you can reference another field name inside a default value field. Perhaps you can use an update query to accomplish the same effect.
    Compwizard
    "There are 10 kinds of people in this world -- those who know binary, and those who don't."

  3. #3
    I believe you have my stapler. scrubz's Avatar
    Join Date
    Feb 2001
    Location
    Van down by the river
    Posts
    254
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bummer. Yeah, I thought about an update query. I was hoping to avoid two calls to the database, but I guess that's what will happen. Thanks.

  4. #4
    SitePoint Evangelist compwizard's Avatar
    Join Date
    May 2002
    Location
    United States
    Posts
    457
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    don't hesitate to ask if you need help with the update query okay!!
    Compwizard
    "There are 10 kinds of people in this world -- those who know binary, and those who don't."


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •