SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2010
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Just uploaded and getting Deprecated error again.

    I just uploaded my site and am getting deprecated errors again.

    New Life Christian Center | Just another WordPress site

    I was reading this thread http://www.sitepoint.com/forums/word...ml#post4778962

    and I see that it is because of my custom theme which I made by modifying the twenty ten theme. Since it is uploaded and the php files are on the remote site (I assume) what do I do? Is there something I need to do in the theme or is there a way I can turn the error display off at the remote site.

    Please help

  2. #2
    Programming Team silver trophybronze trophy
    Mittineague's Avatar
    Join Date
    Jul 2005
    Location
    West Springfield, Massachusetts
    Posts
    17,156
    Mentioned
    190 Post(s)
    Tagged
    2 Thread(s)
    The error messages help
    Warning: Call-time pass-by-reference has been deprecated in
    ...../plugins/gtranslate/gtranslate.php on line 40
    Warning: Call-time pass-by-reference has been deprecated in
    ...../plugins/gtranslate/gtranslate.php on line 63
    Warning: Call-time pass-by-reference has been deprecated in
    ...../plugins/gtranslate/gtranslate.php on line 76
    Warning: Call-time pass-by-reference has been deprecated in
    ...../plugins/gtranslate/gtranslate.php on line 105
    i.e. It is not your theme throwing the errors, but the gtranslate plugin.

    If you don't feel comfortable fixing someone else's code you could ask them to do it. Or maybe disable that plugin or find a replacement for it.

    Maybe someone better at OOP than I am can help. The code in question is
    PHP Code:
    GTranslate::load_defaults(& $data); 
    i.e. the "&" is the "pass by reference"

  3. #3
    SitePoint Enthusiast
    Join Date
    Nov 2010
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just fixed it I put

    php_flag display_errors off

    in the

    .htaccess file

    and it's working fine now I can log in and everything.

    Yeah

  4. #4
    SitePoint Enthusiast
    Join Date
    Nov 2010
    Posts
    74
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Before that I was thinking of replacing the plugin but I couldn't even log in


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •