SitePoint Sponsor

User Tag List

Results 1 to 16 of 16
  1. #1
    SitePoint Guru
    Join Date
    Nov 2002
    Location
    Dubai
    Posts
    714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Do I need to install wordpress again for a non blog website, what is winrar?

    Sometime back, I wanted to learn how to use wordpress and began by creating a blog using a subdomain of my personal site. I do not remember what I did at that time. I now have a blog, which seems to be working ok. Now I want to learn how to make a non-blog website using wordpress.

    I have a few questions which I have listed below:
    I read the following in the wordpress.org site.
    If you want multiple blogs using WordPress, you must actually install each separately (that is, as a separate WordPress installation).
    Multiply is a plugin for WordPress 1.5.x which allows multiple blogs
    Q 1. I am confused with the above 2 statements which seem to be different from each other.
    Now, do I need to download and install wordpress once again for this second site?
    When I went to FTP and opened the wordpress folder and tried to view the index file, I got a message like this.
    Please note that WinRAR is not free software. After a 40 day trial perod, you must either buy a license or remove it from your computer.
    Q 2.What does this mean? Does this mean that I need to buy WinRAR to use wordpress?
    I tried looking at the online tutorials but am getting confused. I am making example sites during my learning curve by creating sites on subdomains. So, this time too, I will create a subdomain for my non-blog wordpress site.
    Again, in the hostgator(my webhost)site, I can see 2 versions of wordpress, 1.2.7 and 1.3,

    Q 3.Which one will I need?

    Q 4. what is the first step that I need to take?
    My site|My blog
    The real failure is not the one who doesn't get his goals but
    the one who gives up.

  2. #2
    SitePoint Addict svcghost's Avatar
    Join Date
    Oct 2010
    Posts
    288
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    WinRAR is just a file extracting program. You can use the free trial I guess if it is forcing you to unzip with WinRAR. You just have to unzip once anyway so it doesn't matter, you won't have to buy it.

  3. #3
    SitePoint Guru
    Join Date
    Nov 2002
    Location
    Dubai
    Posts
    714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, svcghost.

    Do I need to download and install wordpress again? I am still in a doubt regarding this.
    My site|My blog
    The real failure is not the one who doesn't get his goals but
    the one who gives up.

  4. #4
    SitePoint Wizard rguy84's Avatar
    Join Date
    Sep 2005
    Location
    Durham, NC
    Posts
    1,659
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Multiply is an extremely old plugin, I would advise against it. Instead I would read: Create A Network WordPress Codex and see if that suits you better.

    WinRar has both a free and a paid version, I forget the differences. I am 99% sure you don't need the paid version. I have been using the free version for 5 years without any trouble. I only get the 40 day message when I open it. Now I simply hold esc after I click on the file.
    Ryan B | My Blog | Twitter

  5. #5
    Word Painter silver trophy Shyflower's Avatar
    Join Date
    Oct 2003
    Location
    Winona, MN USA
    Posts
    10,053
    Mentioned
    142 Post(s)
    Tagged
    2 Thread(s)
    You only ever need to download the current version of WordPress to your hard drive one time. From there, you will need to upload that version for the different blogs you create, unless you use a plugin that allows you to create multiple blogs from one WordPress installation.
    Linda Jenkinson
    "Say what you mean. Mean what you say. But don't say it mean." ~Unknown

  6. #6
    SitePoint Wizard
    Join Date
    Dec 2003
    Location
    USA
    Posts
    2,582
    Mentioned
    29 Post(s)
    Tagged
    0 Thread(s)
    Also, just note, Wordpress 1.5 is OLD. They're currently up to 3.1, which is what you'll probably want to use with a new site.

  7. #7
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,804
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    WordPress 3 introduced multisite support so that you can run millions of blogs from one WordPress install just as they do on wordpress.com
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">

  8. #8
    SitePoint Wizard rguy84's Avatar
    Join Date
    Sep 2005
    Location
    Durham, NC
    Posts
    1,659
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by felgall View Post
    WordPress 3 introduced multisite support so that you can run millions of blogs from one WordPress install just as they do on wordpress.com
    as mentioned in post #4...
    Ryan B | My Blog | Twitter

  9. #9
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,804
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by rguy84 View Post
    as mentioned in post #4...
    I know. The subsequent discussionstarted talking about WordPress 1.5 and how out of date it is so I thought I'd point out that the page you'd linked to required that they upgrade to version 3 (if the other reasons weren't sufficient to convince them).
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">

  10. #10
    SitePoint Guru
    Join Date
    Nov 2002
    Location
    Dubai
    Posts
    714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you so much for all the replies. As a newbie, I am reading and trying to understand as much as I can from the various replies.

    As I mentnioned in my first post, I had experimented with wordpress only once earlier when I wanted to learn how to use a blog. So, I created a subdomain where I have a blog and it is working.

    When I look at the wordpress folder on my FTP, I can see the version as 2.8.5. Now most of you advice me to use version 3 and I can see that my host, hostgator uses version 3.
    I have the same wordpress folder on my laptop as the one which is there in the public_html folder of my FTP.

    Now, as I am on my path to create a non-blog website by using wordpress version 3, should I download and install version 3 this time and let my old blog continue to run in the older version. A very newbie doubt (It is the host who upgrades their wordpress version and not I who needs to upgrade,isn't it). Once I download and install version 3, can I do the following as mentioned in the next paragraph?

    I read and understood (I hope I have understood correctly) from one of the sites that once I have downloaded the version of WP that I require, I can reuse the same wp-config.php file in that wordpress folder for all my sites ie rename them to include my site name and edit the file with the database information for that specific site. And then I can upload the whole package to FTP and then rename the file back to wp-config.php file.

    Am I on the right path?
    My site|My blog
    The real failure is not the one who doesn't get his goals but
    the one who gives up.

  11. #11
    Programming Since 1978 silver trophybronze trophy felgall's Avatar
    Join Date
    Sep 2005
    Location
    Sydney, NSW, Australia
    Posts
    16,804
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by jppp View Post
    let my old blog continue to run in the older version
    NO NO NO - all versions of WordPress prior to version the absolute latest version contain known security holes that can be exploited to trash your blog (and do who knows what other damage). You should always upgrade WordPress to the latest version as soon as possible after the new version is released. There is an option within WordPress itself now to make that easy to do. Before it was incorporated into WordPress the automatic upgrade facility was available as a plugin so it has been a very long time (version 1.something) since Wordpress required more than a couple of button clicks to automatically upgrade to the latest version.

    Just upgrade your existing blog to the latest version and then turn on multisite.
    Stephen J Chapman

    javascriptexample.net, Book Reviews, follow me on Twitter
    HTML Help, CSS Help, JavaScript Help, PHP/mySQL Help, blog
    <input name="html5" type="text" required pattern="^$">

  12. #12
    SitePoint Wizard rguy84's Avatar
    Join Date
    Sep 2005
    Location
    Durham, NC
    Posts
    1,659
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    JPPP, please follow the instructions at: Upgrading WordPress Extended WordPress Codex
    Since you are upgrading from 1.5 to 3.1 you will need to do some extra steps. The link above is quite detailed and explain things in a straight forward way.
    Ryan B | My Blog | Twitter

  13. #13
    SitePoint Guru
    Join Date
    Nov 2002
    Location
    Dubai
    Posts
    714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Stephen, Ryan, Thanks a ton to both of you. Due to some personal reasons, I was away from my PC for more than 2 weeks.

    Yesterday, I started the upgrade process of my wordpress files. As a first step, I first tried creating a backup of my wordpress database. I am new to this as I have never created a backup before.

    I backed up my wordpress database with the help of
    phpMyAdmin by following the instructions shown in the site, mentioned in Ryan's reply.

    Now I have saved the backup on my computer. It has got
    saved as an sql file with a notepad extension. I want to
    make sure that the backup which I created is actually
    usable. How do I verify this?
    The beginning of my file looks like this.

    -- phpMyAdmin SQL Dump
    -- version 3.3.9.2
    --
    http://www.phpmyadmin.net
    --
    -- Host: localhost
    -- Generation
    Time: Apr 05, 2011 at 12:14 PM
    -- Server version: 5.1.52
    --
    PHP Version: 5.2.4
    SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";

    /*!40101 SET
    @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!
    40101 SET
    @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!
    40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION
    */;
    /*!40101 SET NAMES utf8 */;
    --
    -- Database:
    `jppp_wordpress`
    --
    --
    --------------------------------------------------------
    --
    -- Table structure for table `wp_comments`
    --
    DROP TABLE
    IF EXISTS `wp_comments`;
    CREATE TABLE `wp_comments` (

    `comment_ID` bigint(20) unsigned NOT NULL AUTO_INCREMENT,

    `comment_post_ID` bigint(20) unsigned NOT NULL DEFAULT
    '0',
    `comment_author` tinytext NOT NULL
    ...the rest of the file follows after this. Has the backup been created the way it should be?
    My site|My blog
    The real failure is not the one who doesn't get his goals but
    the one who gives up.

  14. #14
    SitePoint Wizard rguy84's Avatar
    Join Date
    Sep 2005
    Location
    Durham, NC
    Posts
    1,659
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Yes that looks fine. The backup simply takes your database and shoves it into one large file.
    Ryan B | My Blog | Twitter

  15. #15
    SitePoint Guru
    Join Date
    Nov 2002
    Location
    Dubai
    Posts
    714
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, Ryan.

    I have a few more doubts.

    I read the following lines in the site regarding backing
    up of wordpress files.
    Backup ALL your WordPress files in your WordPress
    directory. Don't forget your .htaccess file.
    Now I cannot see any .htacccess file here.

    The following are the folders which I can see in my
    wordpress folder which I have named blog.

    wp-admin
    wp-content
    wo-includes
    The following are the files which I can see.

    error_log
    index.php
    license.txt
    readme
    we-app.php
    wp-atoms.php
    wp-blog-header.php
    wp-comments-post.php
    wp-commentsrss2.php
    wp-config.php
    wp-cron.php
    wp-feed.php
    wp-link-opml.php
    wp-load.php
    wp-login.php
    wp-mail.php
    wp-pass.php
    wp-rdf.php
    wp-register.php
    wp-rss.php
    wp-rss2.php
    wp-settings.php
    wp-trackback.php
    xmlrpc.php
    My wordpress blog has a theme different from the default one.

    I also read the following lines regarding backup of the files.
    Typically, this process involves using an FTP program to
    download ALL your WordPress files from your host to your
    local computer
    Since I have made a backup of my database using phpmyAdmin, if I now use the download method and save the downloaded files, would my job be done Or is there something more to it.

    Of course, after this, I have to learn and see how I am
    able to restore my database.
    My site|My blog
    The real failure is not the one who doesn't get his goals but
    the one who gives up.

  16. #16
    SitePoint Enthusiast Ryo-ohki's Avatar
    Join Date
    Jul 2006
    Posts
    80
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There should definately be an .htaccess file there. Check your FTP settings and make sure it is set to show hidden files. Also be aware that as you had an older version of wordpress your theme may not be entirely compatible with the newest version. I am sure you would be able to find a good free theme though.

    I do believe wordpress has the ability to export content to an xml file as well from the admin section. I would definately do this. I would do a fresh install of the latest version of wordpress to your main website and then just import the data that way. The sql file from your old site and the other files pertaining to the older wordpress install should be kept only for backup purposes. Its really the database that is most important imo as you would be able to find older versions of WP if necessary.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •