SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    Forums Designer
    Join Date
    Jun 2004
    Posts
    422
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE9 weird text alignment issue

    I have a rather complex website, there are buttons on pages that are simple <a> links with image background, making it look like a button.

    Here is an example page: phpBB 3.0 Style : Prosilver

    Buttons I'm talking about are "Change Another Color", "Reset Colors" and far below it "Download". All 3 buttons have exactly the same css.

    Problem is, IE9 shows text on first 2 buttons couple of pixels above of where it is supposed to be.

    Here is a screenshot of bug (mixed parts of screenshots, with arrows showing where bug is): http://www.trushkin.biz/temp/ie9_bug1.png

    I don't see any difference at all in css for those buttons. They should be exactly the same, but they aren't in IE9.

    Any ideas on what could be causing that bug?

  2. #2
    SitePoint Addict EarlyOut's Avatar
    Join Date
    Mar 2011
    Location
    Sector R
    Posts
    279
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This rings a bell:

    http://www.sitepoint.com/forums/css-...de-745359.html

    The difference in your two buttons appears to be that the "misaligned" one has a letter in it (a "g") with a descender, and the other doesn't

  3. #3
    Forums Designer
    Join Date
    Jun 2004
    Posts
    422
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you that solved the problem.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •